UNIT 11 COMMUNICATING WITH GRAPHICS

Structure
11.0 Introduction
11.1 Learning Outcomes
11.2 Graphics in Instruction
   11.2.1 Use of Graphics in Printed Instructional Materials
   11.2.2 Appropriate Use of Graphics
11.3 Graphics File Formats
   11.3.1 Vector and Raster Graphics
   11.3.2 Comparison of File Formats
11.4 Motion Graphics and Animation
   11.4.1 Animation using Computer Software
   11.4.2 GIF Animation
11.5 Colour Theory
11.6 Graphic Design Tools
   11.6.1 OpenOffice.org Draw and Impress
   11.6.2 MS-Paint
   11.6.3 GIMP
   11.6.4 Picasa
   11.6.5 Digitizing Graphics
11.7 Tools for Concept Mapping
11.8 Let Us Sum Up
11.9 Keywords
11.10 References and Further Readings
11.11 Feedback to Check Your Progress Questions

11.0 INTRODUCTION

A picture is worth a thousand words! Be it a graph, a drawing, a map, or a photograph, it is possible for us to pack a lot of information into it. We use the word Graphics for any of these visual representations of information. You would have observed that books, newspapers and magazines are increasingly using graphics to communicate. With the aid of computer software, graphics have evolved into a very powerful and sophisticated means of visual communication.

Observe a graphic in a newspaper – say a bar chart or graph in the economics section, or a cartoon. Compare this with the cover of a glossy magazine. In what ways does this limit the ability to communicate? Make a collection of different graphics and analyse them. For what purposes would you use each kind of graphic? Are some types more suited for particular kinds of communication?

Television and computer animation have combined to add yet another dimension to graphics – motion. A simple graph, where the curve or the bar grows to depict an increase in the quantity, makes the visual representation more appealing. How does combining motion with graphics help enhance communication? Observe different motion graphics and analyse them. For what purposes would you prefer motion graphics?
Graphics are used not only to communicate information, but also as decorative elements (borders, boxes, corners ...) to embellish the message. Greeting or Invitation Cards, Posters or Notices, Covers of Books, Web Pages or logos – you will find hundreds of examples of graphic elements in use.

Lines and curves, colours, light and shade, lettering (font, type size and highlighting) are the different elements, a graphic is made of, each element having a definite purpose in the communication. While there are no rules for what elements should be used in what combination for what effect, a general sense of aesthetic appeal (it is pleasing to the eye) will help you decide. Moreover, different people have preferences for different colours and different designs. If you observe traditional graphic forms, different cultures have different motifs and designs.

In this unit we will examine graphics, analyse its use, learn to generate graphics using different computer software, and use them as a part of different types of communication. In the process, we will also learn about colour and design.

11.1 LEARNING OUTCOMES

After working through this unit, you are expected to be able to:
- Identify different types of graphics and graphic formats;
- Describe the principles of graphic design;
- Use graphic design tools to communicate concepts and ideas; and
- Use concept mapping tools.

11.2 GRAPHICS IN INSTRUCTION

Graphics, as we mentioned earlier is a technique of visually representing information, where with the use of various graphic elements, the message is highlighted. It is expected to draw and hold the attention of the viewer. The message itself is represented in ways that modifies the perspective, links it with other popular events, images or styles, distorts particular aspects so as to highlight it and makes it funny, and so on. We also mentioned that graphics are used for decorative purposes. Most posters and banners have the purpose of advertising a message and use graphics to enhance communication.

How are graphics used in instruction? How will its use be different? Let us examine two possible uses of graphics – one in printed materials like textbooks; two as a teaching aid, either as a projected slide or as a web page, say a part of an online learning package. In the following discussion, we will restrict ourselves to these two uses only.

11.2.1 Use of Graphics in Printed Instructional Materials

Traditionally, one would encounter only a few types of graphics in textbooks. One would find diagrams (say in a biology text) or pictorial representations of models (say in a chemistry or geometry text), maps (say in a geography text), graphs (say in algebra or physics texts) or flow charts. Occasionally, some authors may prefer a comic strip or a cartoon. Let us examine each of these types of graphics in order to understand their characteristics.

Diagrams are generally a simplified version of the real thing. For instance a diagram of say the circulatory system in the human body may only contain...
the heart connected to a few bunches of arteries and veins (Figure 11.1). Depending on the specific purpose of this graphic, details would be highlighted. For instance, if the purpose was to show the process of circulation, then perhaps the different sections of the heart would be shown in a cutaway of the heart. The graphic would be labelled. Again depending on the age of the potential viewer, or the depth to which the content is elaborated, the labels would be in simple English or loaded with jargon.

Figure 11.1: A schematic diagram of the human circulatory system

Diagrams can range from very simple line drawings to very elaborate coloured three-dimensional drawings. Labelling may also range from simple to complex. The rule of thumb for a good diagram is the match between the specific purpose of the diagram, the level of the viewer and the complexity of the subject matter. Compare the diagrams of a cell in a middle school science textbook and a textbook of physiology used by students of medicine. How are they different?

Maps are a specialised form of graphic. Usually used to represent a geographical region, they can also be used to present a variety of information relating to that geographical region. For instance, you can have a map depicting roads connecting different places in a country or the religions practised in different parts of that country or the location of tourist attractions or the crops grown in different parts of the country or even the weather pattern across that country. The distinguishing characteristic of a map is that it is a scaled down version of the real thing – the ground.

What makes a map an effective graphical communication? If the map is a physical map of a region, it will depict the relative elevations, the differences in vegetation, water bodies (perhaps even the depths), and the locations of many important places. Obviously it would not be advisable to depict all the possible information on it. That would make it impossible to decipher. Avoiding clutter or information overload, use of colour such that different features are distinguishable and clear coding (use of icons, colour codes, symbols, etc.) to facilitate easy retrieval of information are the hallmarks of a good map. Study a range of maps and check to what extent they meet these criteria. How could you have made it more effective?
Graphs are also a specialised form of graphic, specifically used for making comparisons of quantities. Pie charts, X-Y graphs, bar charts, etc. are different forms of visual representation of relationships between the quantities being compared. Let us take the case of an X-Y graph (Figure 11.2). This is a typical case of representing what happens to quantity Y, while X increases or decreases. For example, you could represent the change in speed of a vehicle with time. So you have time represented on the horizontal (x-axis) and the speed on the vertical (y-axis). The jagged line on the graph permits us to read the speed at any given point in time. You also observe that both the x and the y axis have a scale, which makes the readings exact.

Flow charts are used to represent a process or an algorithm. Each of the steps are displayed in boxes the process and the sequence indicated by arrows connecting these boxes. Represented this way, it helps the reader easily figure out the complete sequence of events and their relationships. Similar in function to a circuit diagram, it also helps in analyzing or managing a process. It can be of great help in troubleshooting (finding errors and attributing reasons for them), like in the case of a faulty computer programme. A particular kind of flow chart, called an organisational chart or organogram is used to represent the hierarchical relationship between various offices or officers within an organisation (Figure 11.3).

What should the characteristics of a flow chart be? Obviously, the reader should be able to see all the steps clearly, identify their relationships, and identify the sequence of events. If there are different categories of steps or relationships, one may resort to colour coding or using different types of boxes.
11.2.2 Appropriate Use of Graphics

Graphics, you would have observed is an economical and visually enriching style of communication. But inappropriate use would distract or even lead to miscommunication. While using graphics you could work with a few thumb rules. Remember, none of these are sacrosanct, but will aid effective communication.

- Identify the particular type of graphic suited to the purpose of communication;
- Select a style which clearly highlights the information;
- Size of the graphic should be proportionate to the importance of the information - very small or very huge graphics may not serve your purpose;
- Titles, captions, labels, legends, icons, and other markers should be legible, suitably located, proportionately sized and of an appropriate colour and font.
- Use of decorative elements – colours, patterns, borders, shadows or stylised fonts – should be carefully selected to aid communication.

Computer graphics software provides too many choices and very elaborate and purely cosmetic elements. These may not be very helpful for instruction. Discretion in use is very essential.

Check Your Progress 11.1

Notes: a) Write your answer in the space given below.
       b) Compare your answer with the one given at the end of this unit.

What types of graphics will you use and the feature to highlight the following example?

a) A discussion on the fuel crises
b) A report on votes polled by different parties in an election
c) A building plan

................................................................................................................................................
................................................................................................................................................
................................................................................................................................................
................................................................................................................................................


### 11.3 GRAPHICS FILE FORMATS

Now-a-days almost all of printing and video tasks are accomplished by computer software applications. While introducing you to the details of these software or their use is beyond the scope of this unit, it would certainly be helpful if you are familiar with the basics of computer graphics. Computers handle digital data. They can process numbers, very rapidly, very reliably, and tirelessly. Computer scientists have succeeded in employing these capabilities to help computers process images. Again we will not be able to describe these in detail, but we will try to give you an overview.

The screen of a computer monitor (or display unit) displays the graphic to us. Imagine a large number of horizontal and vertical lines crossing each other dividing the rectangular screen into a very large number of tiny squares. To give you an idea of how many such squares are used, do the following:

- Right-click anywhere on your computer desktop (minimize all windows before you do this) and select properties from the pop-up menu;
- Select the settings tab;
- Observe the numbers in the section titled screen-resolution;

You will see a number, such as $1024 \times 768$ or $1280 \times 1024$ or $800 \times 600$ (in older computers). What does this mean? The number $1024 \times 768$ means that your screen is divided into 786432 squares (the product of 1024 verticals and 768 horizontals). Each of these small squares is called a *pixel* (meaning picture element). So each pixel can be considered the smallest unit of an image. Each pixel carries information about the colour and opacity of a particular part of the image. Together, all the pixels arranged in a rectangular grid help generate the graphic, which we see on the monitor (see Figure 11.4).

If the number of such pixels is increased (or alternately, the size of each pixel is reduced and pixels packed together) the image becomes sharper and more detailed.

#### 11.3.1 Vector and Raster Graphics

The way the computer generates these images leads to two broad categories of graphics, *rasters* and *vectors*, which we will consider now.
Television and Computer screens are of different kinds. The most common being the Cathode Ray Tube. Increasingly these are being replaced by LCD and LED displays. In order to display an image, the Cathode Ray Tube (or CRT) would scan the ray across the screen, move one step down and scan the screen again, rapidly covering the entire screen (see Figure 11.5). These scan lines were referred to as rasters. The computer broke the image into thousands of pixels, lined them up in the sequence in which the monitor scanned the screen and using this principle, the CRT displayed them in that order.

![Figure 11.5: Scanning process in a cathode ray tube monitor](image)

What information should each of these pixels contain? Obviously, information about the colour to be displayed as well as information about its opacity (without this the image would appear flat). This process of converting an image into a sequence of pixels is referred to as rasterisation and the image so generated called a raster image.

Remember that the computer actually stores numbers made up of zeros and ones. So each pixel is actually a series of numbers representing the colours and opacity. Each number is a bit and a pixel therefore, is a map of that series of numbers. A raster image is therefore also referred to as a bitmap.

Yet another process by which computers understand images is by breaking down the image into lines and curves, related to each other by mathematical equations. We refer to these as vector images.

For our purpose, it suffices to know that bitmaps or raster graphics are commonly used to represent photographs, and vectors are preferred where line drawings are used. While both types can be used for all kinds of images, they lead to very different file sizes and depending on the purpose, the choice becomes obvious. One other major difference between these two types appears when you scale the image (increase or decrease its size). While a vector graphic retains its quality, the raster image breaks down into small squares, losing all its detail (see Figure 11.6).
11.3.2 Comparison of File Formats

Using either rasters or vectors, computer graphics software generate and save graphics in a variety of file formats. Each of these formats have been evolved with a specific kind of output in mind. We will examine a few of the commonly used formats and compare their characteristics.

If you are familiar with the naming of computer files, you will know that the file extension (the latter part of a file name, e.g. .bmp, .jpg) is the easiest way of recognising the file format. Each such file extension represents a set of rules governing the encoding and decoding of information. The commonly used raster or bitmap graphic file formats are .bmp, .gif, .jpg, .png, .tiff, .tga; commonly used vector graphic file formats are .svg, and .pct. Most computer graphic software use their own special file formats, allowing them to retain more information. For instance .cdr is the vector graphic format used by Corel Draw®, while .psd is the raster format used by Adobe Photoshop®.

For the purpose of this section, we will use the Free and Open Source software GIMP. You could also use any other image editing software like Adobe’s Photoshop®, Corel’s Photopaint®, etc. Start with a graphic of your choice. You could start with a photograph or a line drawing, a map or a graph. If the graphic was already on your computer, note down the file format and the file size. Open the file in the image editing software. Save a copy of this file (use Save As or Save a Copy). In the option available for selection of file format, choose GIF (.gif). Save the file (See Figure 11.7). Repeat this process saving the file as JPG (.jpg), BMP (.bmp) and PNG (.png). Now you have four copies of the same file. What differences do you expect between each of these files? Open the folder in a new window and switch to Details View. Observe the column where file sizes are listed. What differences do you observe? Remember, you have four different files containing the same graphic. Which format gives you the smallest file size? Which format gives the largest file size? (see Figure 11.8).
Open all the four files in your image editing software and place them side by side. Do they look alike? Are they different? How? You will also observe there are differences in the quality of the image. Use the zoom tool to expand each of these images, say to 400%. What do you observe?

Each image format has been specifically designed to meet particular requirements. For instance, GIF or Graphics Interchange Format has been designed for web-based graphics. It reduces the file size by using a colour palette that contains a limited number of colours. It can handle a maximum of 256 colours. Typically the GIF format is used for small graphic elements...
like logos, decorated text, or small animations, where the number of colours and variations in shades are minimum. If the image you chose is a photograph with a variety of shades, you will notice that the GIF format loses a lot of information. The GIF format can store a sequence of images and play them out as an animation.

The JPEG (Joint Photographic Experts Group) or JPG format also compresses files, making them small. But it loses information while compressing. We refer to this as a lossy compression. This format is preferred for saving photographs as it provides a range of saving options to balance the compression of the image size compared to image quality. If you zoom into a jpg image, you will notice the losses in information. Surprisingly, each time you save a file as JPG, it is recompressed losing more detail. So it is best to keep the original image and make a fresh JPG each time. Overall, if you want to compress a continuous-tone image, JPEG is the way to go. It is not ideal for saving line drawings, high-contrast pictures.

The BMP, otherwise known as Windows Bitmap, is a file format specific to Windows. BMP is actually the native file format for Microsoft® Paint. This format supports files containing up to 16 million colors. It also saves your documents using RLE (Run-Length Encoding), which is a lossless compression. What does that mean? Basically, when you save your file using a lossless format, it takes the file and condenses the information so that it takes up less disk space while retaining all of the image data. Notice that this format should have yielded the largest file size.

PNG, pronounced as “ping” (Portable Network Graphics) files are also designed for the Web. They can work with up to 16 million colors. This format supports RGB, indexed color and grayscale imagery. It even gets rid of those little artifacts associated with JPEGs. Some of the older browsers may require a plug-in to display .png files correctly.

## 11.4 MOTION GRAPHICS AND ANIMATION

Animation is a technique of displaying a collection of images, in a sequence, so as to simulate a moving scene. In fact cinema itself uses this technique. If you happen to physically view a portion of a film reel, you will notice that each frame is a snapshot of a particular instant. And every subsequent frame is similarly a snapshot of the event a little later than the preceding frame and a little before the succeeding frame. All of your favourite cartoons are made this way.

### 11.4.1 Animation using Computer Software

Computer software specifically designed to aid such animation have the ability to combine and playback such image sequences. But remember, that the software itself can do very little. The visualisation and generation of the images will have to be done by you. Some software have the capability to ‘tween’, that is to generate the in between images when you define the start and end points. But for this to happen, the software should be able to compute the sequence of changes. Generally, physically moving an object across the screen, of growing it, or changing its colour or a combination of these can be easily achieved mathematically.

Some very sophisticated modelling and animation effects are achieved using such software. In fact, animation has grown into a very large industry world
Communicating with Graphics

wide and is in great demand, particularly for the film and advertising industry. For our purposes, motion graphics and animation would have two purposes. One, to use effects aimed at highlighting information and two to communicate concepts involving changes in space and time. Let us consider a few typical examples and the techniques of achieving this.

Slides shows are a common technique of making presentations. Many of you would be familiar with Microsoft Power Point®. In fact every Office suite of software consists of a presentation application. Two kinds of animation effects are used here. One, where elements on a slide move; perhaps you have a set of bulleted points you wish to reveal one at a time, as your lecture progresses. Such effects can be used for progressively labelling a diagram, highlighting some part of the slide, say image or text, by changing its font, colour or moving it, or for actually plotting a graph as you describe the changes. Two, when you move from one slide to another, the previous slide gets replaced by the current slide through an effect. We refer to this as a transition. These transitions of course may not have any educational importance, and is mainly used as a decorative eye catcher.

Making an elaborate visual communication of a process, say how a petrol engine functions, would require very elaborate graphics and animation. This would not only require detailed drawing tools but also tools to animate different parts of the object and combine them together on a time line. One very commonly used software application for such animation is Adobe Flash®. This software is a vector graphics application and can be used to develop very sophisticated multi-layer drawings. It also has a time-line on which you assemble the scenes into a complete movie, supporting it with different kinds of effects and transitions. You can also associate the scenes with an audio recording, say music or a commentary. The output could be in the form of a gif animation, an image sequence, a movie file (*.avi) or a shockwave file (*.swf). Recent versions of Flash also export to formats suitable for playing movies over the Internet. The animation so produced can run independently and can also have interactions built into it. This latter feature is particularly suitable for making interactive multimedia packages.

There are of course a large number of software applications used for two dimensional and three dimensional models and animations. Some of these are very sophisticated and are even used to make digital effects for movies.

11.4.2 GIF Animation

As we mentioned earlier, the GIF format is capable of playing out a sequence of images one after another in a pre-specified speed. This allows us to depict transitions – say a rotating logo, an animated border or line or a slide show. Given the limitations of the file format itself, this feature is no more used extensively. Most graphic software like GIMP, Adobe ImageReady, Corel PhotoPaint allow you to save a sequence of images as an animated GIF file.

11.5 COLOUR THEORY

Colour is among the most fascinating aspects of nature and it has been humankind's endeavour, not only to understand it, but also to learn to mimic it in their works. The human eye is equipped with two kinds of sensors, one which recognises brightness and the other which senses colour. It would be interesting to note, that not all animals are equipped with this capability.
When we recognise something as coloured, let us say, green leaves, we are simultaneously recognising a number of things. Not all leaves look the same colour. So there is something about the greenness of it. The same leaf would look different in broad day light, as compared to dawn or dusk, when lit up or when in the shade. If the rising or setting sun glow red, the leaf would look different too. The colour of the light also has an effect on what our eyes perceive.

Through the ages, and particularly after Issac Newton established that white light is composed of seven distinct colours and invented the colour wheel, a large number of people have studied colour and tried to present theories about how colours are generated and perceived. While the issue is not clinched – there is still no final acceptable theory of colours, a variety of factors affecting colour have been identified, studied and understood.

For the purpose of our unit, it is not so important to understand the theory, but to explore some of the factors, in order to create the best possible graphic for the given medium – print or non-print.

As we mentioned earlier, there can be different pigments of slightly differing shades of the same colour – there can be many colours which go under a broad class called green. We also mentioned that the same shade of green would appear different under differently coloured light. In fact there are two broad categories of colouring material – paints and light. They behave differently too as we will find out shortly.

Colour theory recognises the existence of primary colours – colours which cannot be generated from other colours; and secondary colours – colours which can be generated by mixing different primary colours. While red, green and blue (RGB) are considered primary colours of light, magenta, yellow and cyan are considered primary colours for paint. They are also known as additive primaries and subtractive primaries respectively. Look at the figure below (Figure 11.9) showing mixing of primary colours that result in the secondary colours. Notice that when the three primaries for light are combined it results in white and the three primaries of paint together yield black.

![Figure 11.9: Primary Colours](image)

Different combinations of particular primary and secondary colours yield other tertiary colours. But, this still doesn’t exhaust the range of colours we perceive.

What happens when you mix white and black? What happens when you mix white or black with a given colour? A pure color mixed with white is called a **Tint**. A pure color mixed with gray is called a **Tone**. A pure color mixed with black is called a **Shade**.
Imagine an equilateral triangle in which you have placed black at one of the vertices, white at another and a particular colour at the third vertex. Further imagine a gradation of colours between the vertices. For instance, if you use the Change Foreground/Background Color palette in GIMP and opt for the colour wheel (Figure 11.10) you can generate all the tints, tones and shades of that colour. Try this out, selecting different colours from the outside wheel in your computer.

Managing colours was a very critical function in the era of black and white television and cinema. Notice that two hues with the same tone would look identical in a black and white monitor. This would lead to effectively flattening and merging two characters, wearing dresses of the same tonal value. With the advent of colour television and cinema and with higher resolution, this is no more an issue.

Yet another way of distinguishing colours is through its hue, saturation and value. While hue refers to the particular colour – red, green, blue, brown, etc., saturation refers to its purity. Imagine a strong decoction of coffee. It would be of a deep brown colour. Now add milk to it, a little at a time, stirring up the mixture continuously. The brown fades each time. If you can add a very large quantity of milk, it would reach a stage, where it would look white. The third dimension, value refers to how bright the colour is. You can imagine a painted board in a room lit by a strong white light. Further, let us say, you have a mechanism through which you can progressively dim the light. What you perceive is the reduction of the value or the brightness of the colour. In the Change Colour Palette in GIMP, you also have sliders for Hue, Saturation and Value. Slide them and see the effect.

When we work with computer graphics using software like GIMP, we have access to an enormous range of colours, because of its ability to modify each of the factors minutely. The limiting factor is indeed the ability of our eyes to distinguish them as separate colours.
Many colours have names, for example you have a ruby red, a topaz green, or a prussian blue. Wikipedia (http://www.wikipedia.org) has a comprehensive write up on colours and their names. But obviously all the shades, tints and tones of a colour cannot be named. So computer software use a code, called the hexadecimal code (16 possible numbers, 0-9, a-f). This code represents each primary colour by a two digit code, thereby representing $16 \times 16 = 256$ possible shades. So you have the possibility of $256 \times 256 \times 256$, which is 16,777,216 colours. The hexadecimal code or the hex code for pure red is ff0000 (red=full/256, green=zero and blue=zero), pure green would be 00ff00 and pure blue would be 0000ff. Black would be 000000 and white ffffff.

**Check Your Progress 11.2**

**Notes:**

a) Write your answers in the space given below.

b) Compare your answers with those given at the end of this unit.

1) What are primary colours? Why do you think light and paints have different primary colours?

............................................................................................................

............................................................................................................

............................................................................................................

............................................................................................................

............................................................................................................

2) Are some colours more visible than others during sunset? How do you account for it?

............................................................................................................

............................................................................................................

............................................................................................................

............................................................................................................

............................................................................................................

3) Using a graphic software’s colour wheel, choose a primary colour palette, say blue. What is the closest shades of blue you can distinguish as separate colours?

............................................................................................................

............................................................................................................

............................................................................................................

............................................................................................................

............................................................................................................

4) What do you think is the utility of a hexadecimal code for colours?

............................................................................................................

............................................................................................................

............................................................................................................

............................................................................................................

............................................................................................................
11.6 GRAPHIC DESIGN TOOLS

In this section, we will explore some common and free graphic design tools. While this cannot be a comprehensive tutorial on these tools, it will help you learn yourself to create simple graphics with them. Like with any software, the more you practise, the more familiar you will be with various capabilities of these tools.

11.6.1 OpenOffice.org Draw and Impress

Open Office.org, commonly known as Open Office is a suite of office applications, including a word processor (writer), a spreadsheet application (calc), a mathematics equation editor (math), a drawing application (draw), a presentation tool (impress), and a database application (base). Together, they form a powerful set of applications. The special feature of this suite is that it is a free and open source software and is tightly integrated, allowing the features of the separate applications to be used in each other.

In the following paragraphs, we will look at the features of two of these applications, viz., draw and impress.

Download and install OpenOffice.org. This suite is available for windows as well as linux operating systems. Most linux distributions will automatically install OpenOffice.org.

Open the application OpenOffice.org Draw. Before we actually use it, let us briefly look at the features of this application:

- OpenOffice.org Draw lets you create simple and complex drawings and export them.
- Draw allows insertion of tables, charts, formulas and other items created in OpenOffice.org programs into your drawings.
- Draw creates vector graphics using lines and curves defined by mathematical vectors.
- You can create simple 3D objects such as cubes, spheres, and cylinders in Draw and even modify the light source of the objects. Grids and guides provide a visual cue to help you align objects in your drawing.
- You can connect objects in Draw with connectors to show the relationship between objects. This is useful for creating organization charts and technical diagrams.
- Technical diagrams often show the dimensions of objects in the drawing. In OpenOffice.org Draw, you can use dimension lines to calculate and display linear dimensions.
- Draw includes a gallery containing images, animations, sounds and other items that you can insert and use in your drawings as well as other OpenOffice.org programs.
- Draw can export to many common graphic file formats, such as BMP, GIF, JPG, and PNG.

Let us create a simple process diagram in Draw, depicting the flow of energy in a typical food chain. Notice the drawing toolbar displayed at the bottom of the application window. If this is not visible, go to View ->Toolbars and select drawing.
Select any shape (the rectangle, ellipse, or from the basic shapes tools). You will observe a coloured shape on your page. You can change the colour by selecting a colour of your choice from the Area style/ filling option in the line and filling toolbar. Repeat this process to create four separate shapes (Figure 11.12).

Now arrange them on the page. When you click on any shape, handles appear, which allow you to resize them. Clicking inside the shape shows a cursor with four arrows pointing in four direction. You can now drag the shape to any place on the page. When selected, you can delete a shape too by pressing the delete button on your keyboard. A right-click will reveal a number of other options which you use to modify or reorganise your drawing. (See Figure 11.13).
Select the text tool on the drawing toolbar. Click inside a shape. Do you observe a textbox with a blinking cursor. Type a label to show meaning. Repeat this process with each of your shapes. (See Figure 11.14)

Select lines and arrows or connectors. Draw arrows or connectors to join the shapes according to the process flow.

Your diagram is complete. But notice, if you move any of your shapes, connectors or textboxes, the drawing will be disturbed. To ensure they behave as a single diagram, you need to group them. Select all the elements. You can do this by pressing Ctr+A, click dragging your mouse over the entire page or selecting Edit -> Select All. Observe the handles now define a rectangle covering all the elements. Right-click inside this region and select Group from the options. Test it by dragging any of the elements. Do all the elements move together? You can ungroup them anytime. You may also enter the group and exit it in order to modify any element. Once grouped, you can even copy the process diagram and paste it into any other application, as if it was a single object. Save your file.
We have explored only one small feature of Draw. Play around with its various features and options, making different drawings to find out how powerful this application is.

Now we will explore OpenOffice.org Impress. This application allows you to make slide shows. As before, let us look at the features list before we proceed to make a presentation.

- OpenOffice.org Impress lets you create professional slide shows that can include charts, drawing objects, text, multimedia and a variety of other items.
- Many of the tools for creating vector graphics in Draw are available in Impress.
- Impress provides you with templates to create professional-looking slides. You can also assign a number of dynamic effects to your slides, including animation and transition effects.
- Impress also lets you rehearse the timing of your slide show. OpenOffice.org Impress gives you the choice of running a slide show automatically or manually.
- You can publish your slides on-screen, as handouts, or as HTML documents.

We will make a simple four slide, slide show. Each of our slides will contain a heading and a graphic. We will then insert transitions between slides and finally play it out as a slide show.

Open Impress in OpenOffice.org. Observe the panels on both sides of the work area. The left panel will show the four slides we will create. The right panel allows us to select a master design, a layout for the content on our slide, animations for the content, and slide transitions.

Let us select a layout, say with a title and a graphic. As soon as you select it, the slide in the work area acquires the layout. Click on the title bar and type in your title. Now double click on the icon in the graphic’s box. You will see a set of options for inserting a spreadsheet, chart, drawing, formula or text. If you want more options, select further objects and click OK. You will be shown a further set of options, which includes literally anything that can be
inserted including a video clip or a sound file. Let us select a bitmap image by clicking on Insert-> Picture-> From File (See Figure 11.16).

To insert the next slide, go to Insert -> Slide. A new slide with the same template appears on the screen. You will also see both the slides in the left panel. Alternately, you can also choose Insert -> Duplicate Slide. In this case, a copy of your slide is generated. Repeat this process two more times, generating four slides in all. Type in the titles in each of the slides. You may insert any of the objects we mentioned above – a drawing, a chart, a spreadsheet, or even a piece of text. Save your file.

Now we will apply transitions and convert the set of slides into a slide show. Transition is the effect which plays when a slide is displayed, for example a wipe, the second slide wipes out the first slide. Go to Slide Show -> Slide Transition...

Observe the new Slide Transition panel on the right with various options for the transition effects (Figure 11.17). You may choose to apply the same
transition to all slides or different ones to different slides, although the latter would be distracting. You can also define when and how the slide transits. Preview the effect you used. Once completed, you may run the slide show to preview your work. Go to Slide Show -> Slide Show.

There are a variety of slide layouts, transitions, animation effects, colours and textures that you can play around to make your slide show interesting. You may also like to publish your slide show on the web, or as a pdf document, or generate handouts. Do spend time exploring the various options, till you become familiar with the different tools offered by the application.

### 11.6.2 MS-Paint

Owing to the fact that this is a standard component of the Windows Operating System, most computer users have been introduced to it. In fact, many computer training programmes use MS Paint as a means to teach mouse control. This software application has a limited, but useful set of functions. We will explore a few of them and suggest that you try out the various features.

As its name suggests, MS Paint is a painting software. So what you are presented with are a canvas, a colour palette, brushes, a few text and shape tools. When you start this application, (go to start -> programs -> accessories -> paint) you begin with a blank canvas.

![MS Paint Program](image)

**Figure 11.18: The MS Paint Program**

You may begin with the selection tool and define a shape. Paint within it or fill it. You may begin with a brush or pen (notice an options palette opens out below giving you choices for brushes). You may also begin with pre-defined shapes (rectangles, ovals and polygons). Notice the colour palette at the bottom. If you are not happy about the colour choice, go to Colors -> Edit Colors. If you click on Define Custom Colors, you will have a full choice of colours.
Remember, we said MS Paint provides a canvas. Once you put an object on it, that's it, you cannot select it and move or modify it. You can of course use the undo option (ctrl-z) to go back one step.

Using the text option along with shapes, you can create quite elaborate graphics. If you prefer the artists way, you can paint your own picture. The images are saved in windows' native graphic format, .bmp.

11.6.3 GIMP

GIMP stands for GNU Image Manipulation Program and is released under the GNU General Public Licence, which makes it a Free and Open Source software, giving you permission to freely use, distribute and even modify (if you know how to).

GIMP as its name suggests helps you manipulate images. You can start with a blank canvas and generate your own graphic, like you did with MS Paint. Or you can open a photograph or a scanned image and modify it. For a beginner, the sheer variety of tools and options can be intimidating. In fact, most software applications, even your word processor, have thousands of tools and options. Of these you use only a few to begin with. As you become more and more familiar and the tasks you attempt become more complicated, you will begin to use more and more tools and options.

![Figure 11.19: The GIMP interface](image)

In order to become familiar with the GIMP interface, we will attempt to make a poster. Let us identify the tasks we will have to undertake:

- Define the size of the poster
- Work out a rough design, including the background image, text, borders, etc.
- Implement the design in GIMP
- Ready the image for printing
While the printed posters we see are huge, one does not start off the design process with such a large canvas. We instead use a very high density (dpi) image, which finally is scaled up to the size desired without loss of quality. This is because every computer program needs memory, hard disk space and graphics processing capability and the larger the canvas size, more would be its requirement. Typically, very high resolution graphics, like say a photograph in a glossy magazine, is printed in 300 dpi or higher. Of course, that depends on the size of the canvas and the type of image information. A coloured rectangular band, for instance has no details and dpi hardly matters here, while a close up of a very colourful bird or a jungle scene is likely to have far more colour variation and would require a very high image density.

Let us define the size of our poster. Go to File -> New. A new window with the title Create New Image opens. You have options for setting the height and width of your image. Notice the pull down menu with pixels as the option. Pull it down to see other options. You may indicate your image size in pixels, inches, millimeters, etc. (See Figure 11.20). This is useful when you wish to make an image for the screen (pixels) or for print (inches / millimeters). For our purpose, let us define a size of 10 inches x 8 inches, a size just less than an A4 page and can be printed on almost all printers.

Also notice a button for Advanced Options. Click to open. Now you can also set the resolution (or image density) of your image in pixels/inch or / millimeter, etc. Set it to 72, the default value. Click OK. You now have a blank canvas to work with.

The second task is to freeze up your design. See Figure11.22, our final image. You can have your own design, with your own choice of colours. Now we will take you through the steps, generating this final image. In the process, you will explore various features of GIMP. Please note that software applications like GIMP are very complex and learning all its features would be quite time consuming. Our attempt here would only be to introduce you to a path, which will help you explore it on your own.
When you work with GIMP like software you need to become familiar with the concept of layers (Figure 11.21). Remember, when you worked with MS-Paint, if you erased something, all paint you applied on the canvas would be wiped out. This can be inconvenient if you wish to develop a graphic consisting of overlapping regions, for example, you might want a caption placed on a photograph, and would like to try out various colours or fonts for the text. Layers allow you to keep different elements separate and modify them independently. It would be like stacking many transparent canvases one above the other, each containing graphic elements. Using this, you can modify the elements as much as you wish, without affecting other elements. You can also apply special effects to particular layers or modify the properties. This gives us enormous flexibility in developing graphics. As you explore GIMP, you will also recognise a number of ways; layers can be used in increasing productivity and ease of working.

![Figure 11.21: The layers concept in GIMP](image)

Notice that GIMP opens with a canvas, a toolbox palette and a third palette, in which layers, channels, paths are listed. GIMP calls them dialogs, as they allow you to suggest options to the software. Click on the layers icon if the layers dialog is not on the top. Notice the buttons at the bottom of the dialog. You can create, delete layers from here.

First, let us insert a background image. Go to File -> Open and open an image of your choice. Let it be at least as big as your canvas. Remember, you can reduce the size of an image without loss in quality, but the same is not true for increasing it. The image opens in a new window. You may resize the image going to Image -> Scale Image and specifying the desired size (10x8). Go to Select -> All, and after selecting the image, go to Edit -> Copy and copy your image to the clipboard (the temporary space where windows stores copied information). Click on the blank canvas we opened earlier. Go to Edit -> Paste as -> New Layer. Notice, the image you copied is visible as a new layer.

Click on Create New Layer on the Layer dialog. You are asked to specify the size of the layer, allowing you a smaller layer than the original canvas. But for our purpose, we suggest you change the size to 10x8 and the layer fill type as transparency. Using the rectangle select tool from the toolbox, define
Content Creation Tools

a rectangular region on the image, to function as a backdrop to the title you will be inserting in the next step. Click on the foreground colour and change it to a colour of your choice. Use the bucket fill tool from the toolbox and fill the selection. Use the opacity setting slider and set the opacity to 30%. Now you have a coloured rectangular backdrop. Use the move tool to position the rectangle at a location of your choice.

Now click on the text tool, write your image title. Notice that you can define the font, the letter size and the colour of the letters. Click close and you will find a new text layer. You can always edit this text or its properties by double clicking on the text. Use the move tool to position the text within the rectangle. Let us now add a special effect, say a drop shadow to the text. Go to Filters -> Light and Shadow -> Drop Shadow... A new window opens up with various options for the shadow. Make your selections and click OK to accept.

Save the image. Click File -> Save. Notice that GIMP assigns the extension .xcf to the file automatically. This format is GIMP’s native format and retains the layers information. If you wish to send this image for printing, or put it on the web, choose an appropriate file format. Click on Select by File Type to reveal other options in the Save window.

We have tried out a simple exercise in GIMP introducing you to some basic ideas of graphics software. Obviously for a creative individual, there are thousands of options available in the software. Do explore the different tools and options to generate or modify your graphics.

![Image Title](image.png)

**Figure 11.22: The final poster**

### 11.6.4 Picasa

Once you have your collection of photographs and graphics, you would like a convenient way of organising and managing them. There are a number of software applications, which help you do so. Picasa from Google is one such free image management tool. What all can it do?
Communicating with Graphics

Once downloaded and installed, Picasa can look around your hard disk, map it and create albums and collections. It can create slideshows; make a movie from your collection, or even a collage. It can publish your collection to the web. If you have a photograph which needs correction, Picasa also provides some simple tools to do so.

Picasa also has a viewer application. When you open an image in this viewer, it is displayed along with a panel of thumbnails of all the images in that folder, and a set of tools for zooming, editing, navigating, uploading to the web, rotating, printing, and e-mailing. You can use the navigation button to go forwards or backwards, one image at a time, or run it as a slideshow.

Let us explore some of these features. Make a collection of images or graphics in a folder, say, the My Pictures folder. Open Picasa. You should see your images displayed as thumbnails in the right pane. In the left pane, you will find the folders containing the images listed. If you do not see some of the images on your hard disk displayed here, it is because you have not asked Picasa to look for it. Go to Tools -> Folder Manager... and select the folder(s), where you want Picasa to look. You can add description to your images here.

Select an image. Right click on it and select view and edit. The image is now displayed singly in the right pane. The left pane is replaced by a new one, with three tabs – basic fixes, tuning and effects. A number of options for correcting or modifying the image is available. Play around with it. Once you are done, you can click on back to library button above the left pane.
Content Creation Tools

Figure 11.24: The image editing features of Picasa

You can create albums containing select images. Go to File -> New Album and give it a name. Now you can select pictures, right click on them and add them to your albums. When you wish to publish this album on to a CD or a web album, Picasa will manage this activity for you.

Picasa has a large number of options for organising, managing, editing and publishing your image collections. You may like to explore these tools and become familiar with them.

11.6.5 Digitizing Graphics

Till now we have dealt with graphics generated on the computer or photographs already in the digital or electronic form (in the form of a computer file). In this section, we will consider how to import a printed graphic or document into a computer.

The process of converting any image into a computer readable file is referred to as digitisation. Now-a-days you have a number of very convenient devices to do this. The simplest of them is to use a web camera and save the image displayed on your screen. You could also use a digital still camera and upload the file from the camera on to the computer.

A scanner is a specialised device meant specifically for digitisation. The scanner consists of a camera like device which moves along the printed page, taking a continuous picture of the page, one strip at a time. The software then stitches up these strips into an image of the page. This is why the process is called scanning and the device a scanner. A photocopying machine is incidentally a scanner and printer combined.
While scanning is a straightforward way of digitisation, it may result in changes in the image and you should know how to correct them.

If you use a camera, it is likely that the plane of the camera is not the same as the print you have digitised. This leads to a distortion (one edge smaller than the other, even when the original is a rectangle), which can be corrected using the perspective tool in software like GIMP.

Depending on the light conditions, changes in brightness or colour can happen. This again can be corrected with appropriate tools in software like GIMP or Picasa.

Scanners settings may be configured to yield an image, whose canvas size, image size or image density (dpi) may be different from the original. Depending on the purpose for which you are digitising it, you may have to reconfigure these settings in the scanner software. For example, if you want the image to be part of a book, which is to be printed, you may need a high resolution image, whereas, if you want it to be part of a website, a lower resolution image will suffice. You should also be aware of the graphic formats (discussed in section 11.3) you wish to work with and suitably convert (usually, save as) the digital image file.

11.7 TOOLS FOR CONCEPT MAPPING

A concept map is a chart depicting the relationships between concepts. It can be used as a way of organising your thoughts on a topic. At the same time, you could use it to communicate the topic to others. Concept maps have become quite popular with teachers using ICT tools, who use this not only for teaching-learning but also for evaluation.

In our context, we are looking at concept maps as a graphical representation of a subject / topic. Also we are interested in a software tool, which will help us make and present a concept map. One such free software is FreeMind, available from http://freemind.sourceforge.net. Download and install it.

Launch FreeMind and go to File -> New. You will be presented with a new canvas with your first node. Click inside to change the text inside. Now you can attach concept nodes to this. Remember, concepts can be at the same
level – two branches emerging from the main trunk, we call them sibling nodes. The concept can be a sub-concept of the previous one, in which case, we call it a child node. So the map will consist of a main parent node, typically the topic itself and a mesh of sibling and child nodes emerging out from the parent. To attach your next node, go to Insert -> New Child Node or New Sibling Node. You can also start a new map with Insert -> New Parent Node.

![Figure 11.26: A concept map in FreeMind](image)

There are a number of options for the shape of your nodes, the connectors between them, and the colours of the nodes. This not only helps beautifying your map, but also helps visual categorising of the concepts. The text inside the nodes can be plain text or hyperlinks. You can also include images.

Once you complete your map, the page can be exported out as a web page, a pdf or an image. You can then project it in your classroom and use the concept map as a teaching-learning aid. You can also assign the task of constructing a concept map to students, individually or in groups. Observing the process and asking relevant questions can also help evaluate their understanding.

Do tryout this tool and explore the various possibilities.

### 11.8 LET US SUM UP

Some of the important points discussed in this unit are summarized below:

- **Graphics are being increasingly used to communicate.** With the advent of computer software, graphics have evolved into a very powerful and sophisticated means of visual communication.
- **A variety of graphic forms are used in instruction, including graphs, maps, diagrams, and charts.**
- **The specific purposes of communication, effective use of different elements of the particular graphic form, and the level of the viewer have a bearing on the impact of the graphic.**
• Computer graphics software provides too many choices and options. While some of these options are very useful, others could serve a purely cosmetic purpose.

• Digital graphics come in two broad formats – vectors and rasters. Vector graphics are scalable and are suitable for mathematically definable images like line drawings, graphs, etc. Raster or bitmap graphics are suitable for a wider variety of images.

• Different file formats are used to save images in both vector and raster formats. They are inter-convertible. Differences in the way they process images, different formats have different advantages and limitations. File formats like .jpg, .gif, and .png are used for web graphics, .tif, .bmp and .tga are used in video and print applications.

• Combining progressively changing images and playing them in a sequence results in perception of motion. This technique is used in motion graphics, video and animation.

• Colour theory categorises the range of colours into primary, secondary and tertiary colours. While primary colours cannot be generated from each other, combining primary colours results in secondary colours. Different combinations of primary and secondary colours result in the complete range of tertiary colours.

• Red, green and blue are the primary colours of light, while cyan, magenta and yellow are the primary colours of pigments. Colours are further categorised on the basis of their tints, tones and shades or hues, saturation and tonal values.

• Computer graphic software use a colour wheel or similar devices to enable selection of colours. Colours are identified by a 16 digit code and computer software can distinctly identify 256 shades of each primary colour, resulting in 16 million combinations.

• We explored development of graphics using Openoffice.org Draw, Microsoft Paint and GIMP. We also studied the development of a slide show using Openoffice.org Impress and a photo album using Picasa. These software have a large number of features and can be used to develop a variety of graphics for a variety of purposes.

• Concept mapping is a convenient device to depict relationships between different concepts and sub-concepts. This device can be used quite effectively in teaching and in evaluating. We explored the use of Freemind to develop and display concept maps.

11.9 KEYWORDS

Animation: is a process of rapid display of 2D or 3D images to create an illusion of movement.

Concept mapping: is the act of preparing image that shows relationship amongst concepts depicted in it.

Graphics: are used to visually represent information. They can be line diagrams, photographs, and computer generated drawing.

Pixel: is used a short form of Picture Element. It is the smallest addressable screen element.

Raster graphics: is a collection of dots called pixel. When an image is scanned, the image is converted to a collection of pixels called a raster image.

Vector graphics: is a category of images made up of lines and curves that are created mathematically. These are resolution independent and can be stretched or resized.
11.10 REFERENCES AND FURTHER READINGS


11.11 FEEDBACK TO CHECK YOUR PROGRESS

QUESTIONS

Check Your Progress 11.1

a) A discussion on the fuel crises

The very fact that we are discussing the issue, there must be many facets to the issue and many different view points. Much of a report on such a discussion will be textual. Important facts, data comparisons, evidence of effects may constitute the content. Different kinds of tables and graphs would be appropriate to the presentation. Will we have a choice of graphs or will particular types of graphs be more appropriate? Think it over.

b) A report on votes polled by different parties in an election

The report will basically consist of numbers pertaining to various seats, regions, parties and candidates. Again tables and graphs would be appropriate. As comparison of parties is to be made in various constituencies, pie charts would be one appropriate choice. A bar chart or X-Y graph can also be used.

c) A building plan

Obviously, the plan is a diagrammatic representation of a building, with drawings for elevation, floor plan, etc. A detailed drawing drawn to scale would be the choice

Check Your Progress 11.2

1) Primary colours are those colours which cannot be obtained on mixing other colours. For light (also known as additive) red, green and blue are the primary colours. For pigments (also known as subtractive) cyan, magenta and yellow are the primary colours. To understand the difference between the two types of colours, let us consider the example of a colour, say chrome yellow. In the case of light, every colour has a particular frequency associated with it. So, in order to generate light of chrome yellow, you add green and blue in the right proportion to generate a light of chrome yellow colour. When white light falls on an object of a particular colour, the object absorbs all other colours reflecting back only that particular colour. So, for an object to appear as chrome yellow, the pigments in the object should absorb all other colours and reflect back chrome yellow.

2) While sunlight, at noon is the nearest to white light, the presence of dust in the atmosphere, and/or the sun's elevation (how close the sun is to the horizon) will redden the sun. This means the sunlight now contains more of red than of other colours. Therefore this will be akin to watching an object through a red or orange filter. If you look at a green leaf, there is less of green reflected from it, making it appear darker. The green is of a darker shade.
3) Pure blue has zero green and zero red. The different shades of blue will have a little green or a little red, a little black or a little white mixed with pure blue. Let us say you choose the colours 0000ff (pure blue) or 0001ff (blue with a little green) or 0100ff (blue with a little red) can you make out the difference? This of course can only be confirmed by you actually doing the exercise.

4) As we mentioned having names for all the 16 million colours is next to silly. Further as you will learn in the chapter on HTML, it would be very convenient and efficient to send a number from one computer to another and let the receiving computer generate its own colour. File sizes can become really small. Hexcodes are also very useful while matching colours in graphics. Let us say, you are touching up or correcting an image and you need to pick up the exact shade of red – knowing the hexcode will allow you to precisely identify the red. In GIMP for instance, open the original graphic; select the colour picker tool from the toolbox (the ink dropper). Press shift and the left mouse button simultaneously and move your mouse over the image. The click will open up a colour picker dialog and as you move your cursor around, it will show the colours you choose. Notice the details of this colour, including the hexcodes displayed in this dialog.
Content Creation Tools