EXERCISE 22  MAP COMPOSITION

Structure
22.1  Introduction
   Objectives
22.2  Requirements
22.3  Steps for Map Composition in QGIS
   Adding New Map on Print Composer
   Adding Labels
   Adding Image
   Adding Legend
   Adding Scale Bar
   Adding Basic Shapes
   Adding Arrow
   Adding Attribute Table
   Exporting Output in Various Formats
22.4  Home Work: Do It Yourself
22.5  Further/Suggested Reading

22.1  INTRODUCTION
In the previous exercises, you have practised to run query, carry out spatial analysis, create a DEM and perform change analysis. It is important to be careful while creating database and performing spatial analysis because any error may lead to incorrect output. The outputs obtained as a result of spatial analysis are not useful unless you are able to present them in an appropriate way. The GIS outputs are broadly categorised into two ways i.e. non-cartographic and cartographic outputs. You have already studied about these GIS outputs in Unit 12 of MGY-003.

In this exercise, you will learn to compose a map of cartographic output.

Objectives
After working through this exercise, you should be able to:
• compose a map in QGIS.

22.2  REQUIREMENTS
To carry out this exercise, you need to have the following:
• a computer with QGIS installed in it, and
• internet connection for downloading data to be used in the exercise.

Before starting this exercise, you are advised to have your pen/pencil and notebook with you as you will be using them to write down your observations and results obtained while performing this exercise.

22.3  STEPS FOR MAP COMPOSITION IN QGIS
Map composition can be done using Map Composer. The print composer provides growing layout and printing capabilities. It allows you to add elements such as the QGIS map canvas, legend, scale bar, images, basic shapes, arrows and text labels. The map layout properties can be adjusted as per different size, group, alignment and position of each element. The layout can be printed or exported to image formats, postscript, PDF or to SVG. The layout can be saved as template and loaded again in another session.
Open raster and vector layers in the QGIS map canvas and change their properties to give a printable view. After everything is rendered and symbolised, click the New Print Composer icon in the toolbar or choose New Print Composer menu item from File menu.

This opens the print composer with blank canvas as shown in Fig. 22.1. The QGIS map canvas, legend, scale bar, images, basic shapes, arrows and text can be added to this canvas. It will be a good idea to check the functions performed by the buttons provided in the toolbar before adding any map element.

![Fig. 22.1: Print composer](image)

The print composer has three tabs: Composition, Item Properties and Command History. Let us discuss them one by one.

The Composition tab gives provision to set paper size, orientation, the print quality for the output file in dpi and to activate snapping to a grid of a defined resolution. Please note, the check box Snap to grid feature only works, if the grid resolution > 0. If the Print as raster check box is checked, all elements will be rasterised before printing or saving as Postscript or PDF.

The Item Properties tab displays the properties for the selected map element. The settings for the selected map element can be customised by changing the item properties.

The Command history tab displays a history of all changes applied to the print composer layout. With a mouse click it is possible to undo and redo layout steps back and forth to a certain status.

You can add multiple elements to the composer. It is also possible to have more than one map view or legend or scale bar in the print composer canvas. Each element has its own properties and in the case of the map, its own extent. To remove an element from the composer canvas, press the Delete or Backspace key. Let us now discuss the following functionalities of QGIS:

### 22.3.1 Adding New Map on Print Composer

Click on the Add new map from QGIS map canvas toolbar button in the print composer toolbar, to add the current QGIS map canvas. Now drag a rectangle on the composer canvas with the left mouse button to add the map. The Item Properties tab displays various tabs like Map, Extents, Grid
and General options. To display the current map, choose between three different modes in the map item tab:

- **Preview Rectangle** only displays an empty box with a message *Map will be printed here*.
- **Preview Cache** renders the map in the current screen resolution. If there is a zoom in or out the composer window, the map is not rendered again but the image will be scaled.
- **Preview Render** means, that if you zoom in or out the composer window, the map will be rendered again, but for space reasons, only up to a maximum resolution.

Cache is default preview mode for newly added print composer maps.

The map element can be resized by clicking on the *Select/Move item* button from the toolbar, then select the map element on composer, and drag one of the handles in the corner of the map.

To move layers within the map element select the map element, click the *Move item content* icon and move the layers within the map element frame with the left mouse button. After you found the right place for an element, you can *Lock* the element position within the print composer canvas after setting in the right place. Select the map element and click on the right mouse button to *Lock* the element position and again to unlock the element. Also activating the check box *Lock layers for map item* in the *Map dialog* of the *Map Item* tab, locks the element position.

**Map Dialog:** The map dialog of the map item tab provides following functionalities as shown in Fig. 22.2:

The **Preview area** allows defining the preview modes *Rectangle, Cache and Render*, whereas the map area allows resizing the map element specifying the width and height or the scale. The field *Rotation* allows rotating the map element content clockwise in degrees. Further, you can enable the check boxes *Lock layers for map item* and *Draw map canvas items*.

Once the view on the QGIS map canvas is changed by zooming or panning or changing vector or raster properties, update the print composer view by selecting the map element in the print composer and clicking the *Update preview* button.

![Fig. 22.2: Map item properties](image-url)
**Extents Dialog:** The map extent area allows specifying the map extents using $X$ and $Y$ min/max values or by clicking the *Set to map canvas extent* button as shown in Fig. 22.3.

![Fig. 22.3: Extents of map](image)

**Grid Dialog:** The grid dialog of the map item tab provides following functionalities as shown in Fig. 22.4.

![Fig. 22.4: Grid dialog of map element](image)

The *Show grid* check box allows overlying a grid to the map element. As grid type can be specified to use solid line or cross. Also *interval* in $X$ and $Y$ direction, $X$ and $Y$ offset, and the width used for cross or line grid type can be defined.

The *Draw annotation* check box allows adding coordinates to the map frame. The annotation can be drawn inside or outside the map frame. The annotation direction can be defined as horizontal, vertical, horizontal and vertical, or boundary direction. The grid colour, the annotation font, the annotation distance from the map frame and the precision of the drawn coordinates can be defined.
General Options Dialog: The general options dialog (Fig. 22.5) is used to define the colour and outline width for the element frame and to set a background colour and opacity for the map canvas. The Position button opens the Set items position dialog and allows setting the map canvas position using reference points or coordinates. Show frame check box is used to toggle the visibility of the frame.

![General options dialog of map element](image)

**Fig. 22.5: General options dialog of map element**

### 22.3.2 Adding Labels

In the map composer, it is possible to add, position, move and customise legend, scale bar, images and label elements. We will learn here to add a label.

**Label Item Tab:** To add a label, click the Add label icon, place the element with the left mouse button on the Print composer canvas. Position and customise their appearance in the Label item tab.

**Label Dialog:** The label dialog (Fig. 22.6) offers to add text labels to the composer canvas. You can define the horizontal and vertical alignment, select font and font colour for the text and it is possible to define a text margin in mm.

![Label dialog of the label element](image)

**Fig. 22.6: Label dialog of the label element**
General Options Dialog: In this general options dialog box (Fig. 22.7), you can define Frame colour and Outline width for the element frame and set a Background colour and Opacity for the label. The Position and size button opens the Set items position dialog and allows setting the map canvas position using reference points or coordinates. Further, the frame can be toggled to display the element frame with the Show frame check box.

![Image of General options dialog of the label element](image)

Fig. 22.7: General options dialog of the label element

22.3.3 Adding Image

To add an image, click the Add image icon, place the element with the left mouse button on the print composer canvas and position. Customise its appearance in the image item tab.

Picture Options Dialog: The picture options dialog of the Image item tab (Fig. 22.8) provides following functionalities:

- The Search directories area allows adding and removing directories with images in SVG format to the picture database.
- The Preview field then shows all pictures stored in the selected directories.
- The Options area shows the current selected picture and allows defining width, height and clockwise rotation of the picture. It is also possible to add a user specific SVG path. Activating the Sync from map check box synchronises the rotation of a picture in the QGIS map canvas (i.e. a rotated north arrow) with the appropriate print composer image.

General Options Dialog: The general options dialog of the image item tab provides following functionalities as shown in Fig. 22.9:

You can define Frame colour and Outline width for the element frame, set a Background colour and Opacity for the picture. The Position button opens the Set items position dialog and allows setting the map canvas position using reference points or coordinates. Further, the frame can be toggled to display the element frame with the Show frame check box.

22.3.4 Adding Legend

To add a map legend, click the Add new legend icon, place the element with the left mouse button on the Print composer canvas and position it. Customise its appearance in the legend item tab.
General Dialog: As shown in Fig. 22.10, the Title of legend is specified here. The Title Font, Group Font, Layer Font and Item Font name can be changed. You can also change width and height of the legend symbol and add layer, symbol, icon label and box space.
Legend Items Dialog: The legend items window (Fig. 22.11) lists all Legend items and allows changing item order, edit layer names, remove and restore items of the list. After changing the symbology in the QGIS main window, click on Update to modify the changes in the legend element of the print composer. The item order can be changed using the Up and Down buttons or with Drag and Drop functionality.
**General Options Dialog:** In general options dialog box (Fig. 22.12), you can define Frame colour and Outline width for the element frame, set a Background colour and Opacity for the legend. The Position button opens the Set items position dialog and allows setting the map canvas position using reference points or coordinates. Further the frame can be toggled to display the element frame with the Show frame check box.

![General Options Dialog](image)

**Fig. 22.12: General options dialog of legend element**

**22.3.5 Adding Scale Bar**

To add a scale bar, click the Add new scale bar icon, place the element with the left mouse button on the Print composer canvas and position it. Customise its appearance in the scale bar item tab.

**Scale Bar Dialog:** The scale bar dialog box as shown in Fig. 22.13 allows defining the Segment size of the scale bar, Map units per bar unit and how many Left and Right segments should be used. You define the scale bar Style, available is single and double box, line ticks middle, up and down and a numeric style. You can also define Height, Line width, Label space and Box space of the scale bar. Add a Unit label and define the scale bar Font and Colour.

![Scale Bar Dialog](image)

**Navigation tools:** For map navigation the print composer provides following general tools: -
- Zoom in
- Zoom out
- Zoom to full extend
- Refresh the view

**Revert and Restore Tools:**
During the layout process, it is possible to revert and restore changes. You can do this with the revert and restore tools listed below: -
- Revert last changes
- Restore last changes or by mouse click within the Command History tab.

![Scale Bar Dialog](image)

**Fig. 22.13: Scale bar dialog of scale bar element**
**General Options Dialog:** In general options dialog, you can define colour and outline width for the element frame, set a background colour and opacity for the scale bar as shown in Fig. 22.14. The *Position* button opens the *Set items position* dialog and allows setting the map canvas position using reference points or coordinates. Further, the frame can be toggled to display the element frame with the *Show frame* check box.

![Fig. 22.14: General options dialog of scale bar element](image)

### 22.3.6 Adding Basic Shapes

It is possible to add basic shapes (*Ellipse*, *Rectangle*, *Triangle*) to the print composer canvas by clicking the *Add shape* button.

**Shape Dialog:** The *Shape* dialog box allows drawing an ellipse, rectangle, or triangle in the print composer canvas. You can define its outline and fill colour, the outline width and a clockwise rotation as shown in Fig. 22.15.

![Fig. 22.15: Shape dialog of shapes element](image)
General Options Dialog: In the **general options** dialog box, you can define Frame colour and Outline width for the element frame, set a Background colour and Opacity for the shapes as shown in Fig. 22.16. The Position and size button opens the **Set items position** dialog and allows setting the map canvas position using reference points or coordinates. Further, the frame can be toggled to display the element frame with the **Show frame** check box.

![General options dialog](image1)

**Fig. 22.16: General options dialog of shapes element**

### 22.3.7 Adding Arrow

Click on **Add arrow** button and click on the print composer canvas. Position it and edit its properties in the **Arrow** dialog box.

**Arrow Dialog:** The **arrow** dialog box allows drawing an arrow in the print composer canvas. You can define Arrow colour, Line width and Arrow head width and it is possible to use Arrow markers like Default marker, No marker and SVG marker as shown in Fig. 22.17. For the SVG marker, you can additionally add a SVG Start and End marker from a directory of the computer.

![Arrow dialog](image2)

**Fig. 22.17: Arrow dialog of arrow element**
General Options Dialog: In general options dialog box, you can define Frame colour and Outline width for the element frame, set a Background colour and Opacity for the arrow as shown in Fig. 22.18. The Position and size button opens the Set items position dialog and allows setting the map canvas position using reference points or coordinates. Further, the frame can be toggled to display the element frame with the Show frame check box.

Fig. 22.18: General options dialog of arrow element

22.3.8 Adding Attribute Table

It is possible to add parts of a vector attribute table to the print composer canvas.

Table Dialog: The table dialog box allows selecting the vector Layer and columns of the Attribute table as shown in Fig. 22.19. Attribute columns can be sorted and you can define to show its values ascending or descending. You can define the Maximum rows to be displayed and if attributes are to be shown for visible features of the current composer canvas only as shown in Fig. 22.20.

Fig. 22.19: Table dialog of attribute table element

Additionally, you can define the grid characteristics of the table by checking Show grid and the Header and Content font.
General Options Dialog: In general options dialog box, you can define Frame colour and Outline width for the element frame, set a Background colour and Opacity for the table as shown in Fig. 22.21. The Position and size button opens the Set items position dialog and allows setting the map canvas position using reference points or coordinates. Further, the frame can be toggled to display the element frame with the Show frame check box.

22.3.9 Exporting Output in Various Formats
The print composer allows you to create several output formats and it is possible to define the resolution (print quality) and paper size:

- The Print icon allows printing the layout to a connected printer or a Postscript file depending on installed printer drivers.
- The Export as image icon exports the composer canvas in several image formats such as PNG, BPM, TIF, JPG, etc.
- The Export as PDF icon saves the defined print composer canvas directly as a PDF.
- The Export as SVG icon saves the print composer canvas as a SVG (Scalable Vector Graphic).
After completing the exercise submit the following to your instructor for evaluation:

1. Snapshot of a composed map with all the map elements.

## 22.4 HOME WORK: DO IT YOURSELF

1. Download a sample point shape file showing countries of the World from [www.naturalearthdata.com/download/10m/cultural/ne_10m_admin_0_countries.zip](http://www.naturalearthdata.com/download/10m/cultural/ne_10m_admin_0_countries.zip) from the Natural Earth dataset. Extract the shape file from the zip archive and save it on the hard disk.

2. Download a sample point shape file showing states and provinces of the World from [www.naturalearthdata.com/download/10m/cultural/ne_10m_admin_1_states_provinces_shp.zip](http://www.naturalearthdata.com/download/10m/cultural/ne_10m_admin_1_states_provinces_shp.zip) from the Natural Earth dataset. Extract the shape file from the zip archive and save it on the hard disk.

3. Download a sample point shape file showing places of the World from [www.naturalearthdata.com/download/10m/cultural/ne_10m_populated_places.zip](http://www.naturalearthdata.com/download/10m/cultural/ne_10m_populated_places.zip) from the Natural Earth dataset. Extract the shape file from the zip archive and save it on the hard disk.

4. Add these shape files on QGIS desktop. Style the `countries` layer with solid blue line border and solid white brush. Style the `states_provinces` layer with solid blue line and no brush. Style the `populated_places` layer with simple marker in brown colour. Zoom to India. Set the scale to 1:14500000.

5. Select *Map Composer* from *File* menu. This opens the map composer window.

6. In the *File* menu of *Map Composer*, select *Page setup* menu item. The page setup dialog box as shown in Fig. 22.22 opens up. Set the page size to be A4, landscape orientation and also set the margins.

![Page Setup dialog box](image)

**Fig. 22.22:** Page Setup dialog box

7. To add a rectangle boundary to your map, select *Add Rectangle* from the toolbar and draw a rectangle on the *Map Composer* canvas as shown in the Fig. 22.23.

---

195
Spatial Analysis

Fig. 22.23: Add Rectangle tool

8. In the Item Properties of Rectangle, set the Outline Width to be 0.50 and check the Transparent Fill as shown in Fig. 22.24.

Fig. 22.24: Item Properties for Rectangle shape

9. To add a new map, from the Layout menu select Add Map menu item and draw the map inside the rectangle on the Map Composer canvas. In the Item Properties of Map element, set the height, width and scale of map as shown in the Fig. 22.25. Also in the General options tab, set the Background colour to be sea blue.

Fig. 22.25: Item Properties of Map element
Now the Map canvas looks like the Fig. 22.26.

![Map composer with Rectangle and Map element](image)

**Fig. 22.26: Map composer with Rectangle and Map element**

11. From the **Layout** menu select *Add Label* menu item and draw it on the *Map composer* canvas. In the *Item Properties* of Label element give the name of map (Fig. 22.27) and set the font size to be 16 point bold.

![Item Properties of Label element](image)

**Fig. 22.27: Item Properties of Label element**

12. From **Layout** menu, select *Add arrow* menu item and draw it on the *Map composer* canvas. In the *Item Properties* of Arrow element, set the *Line width*, *Arrow head* width and select any SVG marker for arrow from C:\Program Files (x86)\Quantum GIS Lisboa\apps\qgis\svg\north_arrows folder. In this example, north-arrow_5_arrow_in_circle_small_n.svg is selected as shown in the Fig. 22.28.
13. Add a label as `SCALE` on the Map Composer.
14. From Layout menu, select Add Scale bar menu item and draw it on the canvas of Map composer. In the Item Properties of Scale bar element, select Style to be Numeric as shown in Fig. 22.29.
Now your map looks like the Fig. 22.30.

**Map Composition**

**Fig. 22.30:** Map composer with Rectangle, Map element, Label, North arrow and Scale bar

15. To add legend for the map, select *Add Legend* menu item from *Layout* menu and click on the canvas of *Map Composer*. This will add a map legend to the canvas. In the *Legend Item* tab of *Item Properties*, edit the names of layers using the pencil toolbar as shown in Figs. 22.31 and 22.32.

**Fig. 22.31:** Legend item tab of Item properties for Legend element
16. To add attribute table showing population, select **Add Table** menu item from **Layout** menu and click on **Map Composer** canvas. An attribute table is added on the canvas. In the **Table** tab of **Item Properties**, select **Layer** as *ne_10m_populated_places* as shown in Fig. 22.33.

17. Click on **Attributes** button in the **Item Properties** Table tab. This opens up a dialog box showing all the fields of the selected layer. Select only the required fields to be displayed on canvas and add it as shown in Fig. 22.34.
18. Final map will be as shown in Fig. 22.35

![India Map with States and Populated Places](image)

Fig. 22.35: Final composed map

19. Find out how you can compose a map in ILWIS using the same dataset.

### 22.5 FURTHER/SUGGESTED READING