We can also rename a worksheet using shortcut mouse commands. We right-click on the existing sheet name, select **Rename** or double-click on the worksheet name and type a new name as shown in Fig. 1.25.

8. **Adding a New Worksheet**

As shown in Fig. 1.26, to add a new worksheet, we

1. select the **Sheet** tab before which we want to insert a new sheet,
2. click on the **Insert** option in the **Cells** group under the **Home** tab, and
3. click on the **Insert Sheet** option. It will give us a new sheet named “**Sheet 4**” in this case (Fig. 1.27c).
We can also add a new worksheet to the workbook by clicking on the *Insert Worksheet* tab at the bottom of the workbook (to the right of the *Sheet 3* tab) or we can right-click on one of the existing *Worksheet* tabs and select *Insert* as shown in Fig. 1.27a. A new dialog box appears, and we select the *Worksheet* option and click on *OK* as shown in Fig. 1.27b. It gives us a new sheet named “Sheet 4” in this case (Fig. 1.27c).

9. **Deleting a Worksheet**

As shown in Fig. 1.28, to delete a worksheet, we

1. select the *Sheet* tab that we wish to delete,
2. click on the *Delete* option in the *Cells* group under the *Home* tab, and
3. click on the *Delete Sheet* option.

We can also delete a worksheet by right-clicking on its tab and then selecting *Delete* as shown in Fig. 1.29.
10. Re-arranging the Worksheets

We can re-arrange the worksheets to put them at the desired position. As shown in Fig. 1.30, to re-arrange the worksheets, we

1. select the **Sheet** tab we wish to re-arrange,
2. click on the **Format** option in the **Cells** group under the **Home** tab,
3. click on the **Move or Copy Sheet** option shown in Fig. 1.30a. This opens a new dialog box as shown in Fig. 1.30b, and
4. select the location before which we wish to place the sheet in **Before sheet** options. Here we choose **Sheet 3** and click on **OK**. Fig. 1.30c shows that **Sheet 1** is now moved to a position before **Sheet 3**.

![Fig. 1.30](image)

We can also use shortcut mouse commands to re-arrange the worksheets. We right-click on the **Sheet** tab that we wish to arrange, say, **Sheet 1** and choose **Move or Copy** option as shown in Fig. 1.31. It will open the same dialog box as shown in Fig. 1.30b.

![Fig. 1.31](image)
Basic Statistics Lab

We can also move the sheet by clicking on the **Worksheet** tab that we wish to move and dragging it to the desired location without leaving the left button on the mouse. When we drag the mouse, we see a small arrow. We release the left button on the mouse when we see that the arrow is at the desired position. In Fig. 1.32, the arrow is shown between **Sheets 2** and 3. When we release the left button of the mouse at this point, **Sheet 1** is placed between **Sheets 2** and 3 as shown in Fig. 1.30c.

![Fig. 1.32](image)

**Fig. 1.32**

11. Duplicating (Copying) the Entire Sheet

We can also make a copy of the entire sheet in two different ways: (i) by ribbon commands and (ii) by shortcut mouse commands. We first explain how to copy the entire sheet using the **Ribbon** commands. For this, we select all cells of the sheet by pressing **Ctrl+A** or clicking at the top-left intersection of rows and columns, as shown in Fig. 1.33.

![Fig. 1.33](image)

**Fig. 1.33**

We click on the **Copy** option under the **Home** tab as shown in Fig. 1.34 or press **Ctrl+C**.

![Fig. 1.34](image)

**Fig. 1.34**

We select another sheet or workbook in which we wish to copy that sheet and then select Cell A1 in that sheet. Then we click on the **Paste** option under the **Home** tab or press **Ctrl+V** as shown in Fig. 1.35.

![Fig. 1.35](image)

**Fig. 1.35**
We can also use another method to copy the entire sheet. For this, we right-click on the Sheet tab of the sheet that we wish to copy. From the shortcut mouse commands, we select Move or Copy option (Fig. 1.31a). The Move or Copy dialog box enables us to copy the sheet either to a different location in the current workbook or to a different workbook. You should remember to mark the Create a copy checkbox (Fig. 1.36a). A copy of Sheet 1 as Sheet 1 (2) is shown in Fig. 1.36b.

- If we wish to copy data in the existing workbook (by default), we can choose the sheet before which we wish to place this sheet or we can also choose the (move to end) option in the Before Sheet options.

- We can choose the (new book) option in To book to copy in a new workbook. In all cases, we select the Create a Copy option.

We give the new worksheet a suitable name so that it is easy to recognise.

12. Moving around the Worksheets and Cells in a Worksheet

To move from one worksheet to another, we click on the Sheet tabs. The name of the active sheet is shown in bold. It is important to be able to move around the cells of a worksheet effectively because we can type or change data only in the active cell. We can move around the cells using the arrow keys or moving the mouse pointer to the required cell and clicking on it to make the cell active.

In Fig. 1.3, Sheet 1 is an active sheet and Cell A1 is an active cell.

We can also use different keyboard shortcuts to move the active cell:

- **Up Arrow (↑)** – To move the active cell one row up.
- **Down Arrow (↓)** – To move the active cell one row down.
- **Left Arrow (←)** – To move the active cell one column to the left.
- **Right Arrow (→)** or **Tab** – To move the active cell one column to the right.
- **Ctrl + Down Arrow** – To move the active cell automatically to the bottom.
- **Ctrl + Up Arrow** – To move the active cell to the top.
- **Ctrl + Right Arrow** – To move the active cell to the right end.
- **Ctrl + Left Arrow** – To move the active cell to the left end.

To move between the cells on a worksheet, we can also directly click on any cell or use the arrow keys. To see the remaining area of a sheet, we can use either vertical or horizontal scroll bars.
13. Deleting Row(s) or Column(s)

If we select the row or column and just press the **Delete** key, then only the content in it disappears but the blank row or column remains. There may be many situations when we want to delete the entire row(s) or column(s). To delete the row(s) or column(s), we select the row(s) or column(s) that we wish to delete, then click on **Delete** under **Home** tab and choose **Delete Sheet Rows** or **Delete Sheet Columns**, respectively, as shown in Fig. 1.37.

![Fig. 1.37](image)

We can also delete the row(s) or column(s) using the short-cut mouse commands. For this, we select the row(s) or column(s) that we wish to delete, right-click the mouse on the selected row number or column letter, and then choose **Delete** as shown in Fig. 1.38.

![Fig. 1.38](image)

14. Inserting Row(s) or Columns(s)

While working on the spreadsheet, we need to insert row(s) or column(s) many times. To insert row(s) or column(s), we select the row(s) or column(s) before which we wish to insert the empty row(s) or column(s) and then click on **Insert Sheet Rows** or **Insert Sheet Columns** in **Insert** command under the **Home** tab as shown in Fig. 1.39.

![Fig. 1.39](image)
We can also insert row(s) or column(s) using the short-cut commands. We select the row(s) or column(s) before which we wish to place the extra row(s) or column(s), right-click the mouse and then select **Insert** option as shown in Fig. 1.40.

![Fig. 1.40](image)

15. **Cell Reference**

As explained in Sec. 1.3, a new worksheet is a grid of **rows** and **columns**. The rows are labelled with numbers and the columns with letters. Each intersection of a row and column is a **cell**. Each cell has an **address**, which is the combination of the column letter and the row number.

- Refer to Fig. 1.6. Note that Cell A4 is the active cell, which is highlighted with a thick border around it. This cell corresponds to Column A and Row 4. So it is labelled as Cell A4.

- If we are considering entries from Row 4 of Column A up to Row 11 of Column H, we write them as Cells A4:H11. It is the range, i.e., **reference** for these cells.

- Cell references are of two types: (i) relative and (ii) absolute. Most often, cell references are relative but these can also be absolute. Absolute cell references have the prefix $. For example, A4:H11 is a relative cell reference while $A$4:$H$11 is an absolute cell reference.

- **Relative Cell References**: These references can change when the cell references are copied to a new location. For example, if we type “=A2-B2” in Cell C2 and copy Cell C2 to C3 (i.e., move down one cell), the new cell (Cell C3) will be “=A3-B3”. You will learn how to copy the cell references in Sec. 1.6.

- **Absolute cell references**: These references do not change when the cell references are copied to a new location. For example, if we type “=$A$2-$B$2” in Cell D2 and copy Cell D2 to Cell D3 (i.e., move down one cell), the new cell (Cell D3) will be “=$A$2-$B$2”.

- Cell references can also be part relative and part absolute. Sometimes we need to change the row reference when the references are copied to keep the same column reference or vice versa. In such situations, absolute and relative references are combined. For example, $A$4 is absolute Column A and
relative Row 4, while A$4 is relative Column A and absolute Row 4. We can also use the F4 key to create the absolute and mixed references. If we select the reference of Cell A4, we get $A$4, A$4, $A4 and A4 each time we press the F4 key.

16. Selecting the Data

When we work in Excel, we need to select the data on a worksheet many times. We can do this in various ways and you can use any one of them. We have explained that a cell must be active to enter information into it. To select a cell, we click on it. To select a number of cells, we can use one of the following ways:

i) We click on the first entry of the given data, press the Shift key and use the Arrow keys to scroll up to the last entry of the data that we wish to select without leaving the Shift key. For example, if we wish to select the data given in Cells A4:H11, we click on Cell A4, press the Shift key and use the Arrow keys to select the data up to Cell H11 without leaving the Shift key as shown in Fig. 1.41.

ii) We click on the first value of the data, press the Shift key and then click on the last entry without leaving the Shift key. For example, if we wish to select the data given in Cell A4:H11, we click on Cell A4, press the Shift key and then click on Cell H11 without leaving the Shift key. It will select all cells between and including A4 and H11 (Fig. 1.41).

iii) We can also select the data using the mouse. We left-click on Cell A4, hold the left button on the mouse and drag up to the required last cell without leaving the left button. Fig. 1.41 shows the highlighted Cells A4:H11, which we have selected.

![Fig. 1.41](image)

To select several cells, which are not adjacent, we press the Ctrl key and click on the cells, which we wish to select. Fig. 1.42 shows the selected Cells A2, B3, C4 and D5.

![Fig. 1.42](image)

iv) We can also select the entire row or column by clicking on the row number and column label.
17. Inserting a Chart
We can use Excel to construct different types of charts to represent the data diagrammatically. Various chart options are available in the Charts group under the Insert tab (Fig. 1.43). We shall discuss in detail about the construction of various charts in Lab Sessions 3, 4 and 5.

![Charts group in Excel](image)

Fig. 1.43

18. Inserting a Symbol
We can also insert symbols, e.g., $\mu$, $\sigma$, $\alpha$, etc., in a cell of Excel spreadsheet. We first select the cell in which we wish to insert the symbol. To insert a symbol, we click on Symbol in Text group under the Insert tab as shown in Fig. 1.44a. A new dialog box appears as shown in Fig. 1.44b. We click on Insert or we can also double click on the symbol to insert it and then click on Cancel to close the box.

![Inserting a symbol in Excel](image)

Fig. 1.44

19. Inserting a Mathematical Equation
We can also type mathematical equations such as $\bar{x}$, $\sigma_i^2$, $\sum_{i=1}^{n} x_i^2$, etc., in Excel. For this, we

1. click on the Object option in Text group under the Insert tab as shown in Fig. 1.45a so that a new dialog box appears (Fig. 1.45b),
2. click on the Microsoft Equation 3.0 option and click on OK as shown in Fig. 1.45b, and
3. type the required equation using the various options shown in Fig. 1.45c.

**1.6 ENTERING DATA IN AN EXCEL SHEET**

We can enter data in an Excel sheet in many ways. We can

i) type data in a new Excel worksheet,

ii) copy data from an existing Excel worksheet, and

iii) create new data by transforming the existing data.

Besides the above mentioned ways used commonly, we can also use data from other file formats. We are not discussing it here as it is out of the scope of this course.
1.6.1 Typing Data in a New Excel Worksheet

To enter any information in a cell, we first select the cell, say, Cell A1 and begin typing with the help of the keyboard. When we finish entering the information (label or value) in that cell, we

- press *Enter* to move to the next cell below (in this case, Cell A2) or
- press *Tab* to move to the next cell to the right (in this case, Cell B1) or
- click on any cell to select it.

Note that Excel assumes any number typed as positive. If we want to enter a negative number, we use a minus sign “-” or enclose the number in the parentheses “( )”.

We consider a simple example to explain how to enter data. Suppose we have the data of maximum and minimum temperature for 5 days as recorded in Table 1.

**Table 1: Maximum and minimum temperature data**

<table>
<thead>
<tr>
<th>Maximum Temperature (in °C)</th>
<th>Minimum Temperature (in °C)</th>
</tr>
</thead>
<tbody>
<tr>
<td>40</td>
<td>18</td>
</tr>
<tr>
<td>41</td>
<td>20</td>
</tr>
<tr>
<td>38</td>
<td>16</td>
</tr>
<tr>
<td>36</td>
<td>15</td>
</tr>
<tr>
<td>43</td>
<td>21</td>
</tr>
</tbody>
</table>

The data given in Table 1 consist of two columns of information. The first and second columns of the table contain the maximum and minimum temperatures, respectively, for five days. We now start entering this data in an Excel sheet. For this, we

1. click on Cell A1 to make it active,
2. type “Maximum Temperature” in Cell A1, and press *Enter* or press Down Arrow (↓) key to select Cell A2,
3. type “40”, the maximum temperature for day 1 in Cell A2. In the same way, we can type the remaining values up to Cell A6,
4. click on Cell B1 to enter the data of the second column of Table 1,
5. type “Minimum Temperature” in Cell B1,
6. select Cell B2 and type “18”, the minimum temperature for day 1. In the same way, we can type the remaining values of minimum temperature up to Cell B6. The resulting Excel sheet with the data is shown in Fig. 1.46.

![Fig. 1.46](image)
Notice from Fig. 1.46 that the labels of the data given in Table 1, i.e., “Maximum Temperature” and “Minimum Temperature” are in Row 1, i.e., Cells A1 and B1, respectively. The values of data are shown in Rows 2 to 6, i.e., Cells A2:B6. We now save the file as explained in Sec. 1.4. We type the name of the file as “Temperature Data” and save it in a folder named “Basic Statistics Lab” in D drive as shown in Fig.1.47.

![Fig. 1.47](image)

**Changing the Worksheet Name**

We can also assign a suitable name to the worksheet, which contains this data. We select the Sheet tab at the bottom, say, “Sheet 1”, right-click the mouse and select Rename option (Fig. 1.29) or double click on the Sheet tab. Then we give the worksheet a suitable name, say, “Temperature” as shown in Fig. 1.48.

![Fig. 1.48](image)

### 1.6.2 Copying Data from an Existing Excel Worksheet

We consider the file “Temperature Data.xlsx”, which is an Excel 2007 workbook created in Sec. 1.6.1. Suppose we wish to copy the data on the sheet named “Temperature” and paste it on the another sheet, say, “Sheet 2”. For this, as shown in Fig. 1.49, we

1. select data, i.e., Cells A1:B6 given on the sheet “Temperature”,
2. click on Copy option under the Home tab,
3. click on “Sheet 2” tab,
4. select Cell A1 (or any other cell where we wish to paste this data) of Sheet 2, and
5. click on Paste option under the Home tab.
1.6.3 Creating New Data by Transforming the Existing Data

This option of data creation in Excel is very attractive as it makes calculations simple and easy. We can create new data by transforming the existing data. Suppose we open the file named “Temperature Data.xlsx” created in Sec. 1.6.1. We can now create the data of temperature difference using the existing data, i.e., the maximum and minimum temperatures. We shall explain in detail how to type a formula in Excel in Sec. 1.7. For computing the temperature difference, we

1. type “Temperature Difference” in Cell C1,

\[
\begin{array}{cccc}
\hline 
\text{Maximum Temperature} & \text{Minimum Temperature} & \text{Temperature Difference} \\
\hline 
40 & 18 & =A2-B2 \\
41 & 20 & \\
38 & 16 & \\
\hline 
\end{array}
\]

After entering the formula and pressing Enter, the temperature difference is automatically calculated in C2 as 22.

\[
\begin{array}{cccc}
\hline 
\text{Maximum Temperature} & \text{Minimum Temperature} & \text{Temperature Difference} \\
\hline 
40 & 18 & 22 \\
41 & 20 & \\
38 & 16 & \\
\hline 
\end{array}
\]
2. type “=A2-B2” in Cell C2 as shown in Fig. 1.50a [It will compute the value by subtracting the value of Cell B2 from Cell A2 (Fig. 1.50b)], and
3. compute the temperature difference for the remaining days in the same way.

We get the data of temperature difference in Cells C2:C6 (Fig. 1.50c).

These calculations can be done in a simpler way. We now explain how to apply a formula in different cells to get the result with minimum effort.

### 1.6.4 Copying a Formula in Different Cells

When we have to use the same formula in multiple adjacent horizontal or vertical cells, we need to type the formula only in the first cell. We can then copy it into the remaining cells. We now explain how to copy the formula of Cell C2, i.e., “=A2-B2” up to Cell C6 (Fig. 1.51).

Here we discuss two different ways of copying the formula of the first cell in the other adjacent cells:

- **Dragging Down the Formula**

  We can copy the formula using the mouse. For this, we

  1. select Cell C2,
  2. put the cursor at the lower right corner, i.e., drag handle, of the Cell C2 (as a result plus sign (+) appears as shown in Fig. 1.51a), and
  3. left-click the mouse and drag the cursor down up to Cell C6 without leaving the left button (Fig. 1.51b). As we release the left button on the mouse, we get the result shown in Fig. 1.51c.
In this way, we copy the formula “=A2-B2” of Cell C2 up to Cell C6. Note that the formula “=A2-B2” has an relative reference, so it will change accordingly as we drag it down as shown in Fig. 1.51. You can also explore the drag right, up or left options to copy the formula in the right, upper or left cells, respectively.

ii) Fill Option

We can also copy the formula using the Fill option available under the Home tab. For this, as shown in Fig. 1.52, we

1. select the cells starting from the cell that contains the formula and then all cells in which we wish to copy the formula, i.e., Cells C2:C6,

2. click on the Fill option in the Editing group under the Home tab (Fig. 1.52a), and

3. choose Down option which will copy the formula given in Cell C2 down up to Cell C6 as shown in Fig. 1.52b.

![Fig. 1.52](image)

You can also explore the Right, Up or Left options to copy the formula in the right, upper or left cells, respectively.

Note that you can also copy the values other than formulae, i.e., year name, month name, series of numbers, etc., using these two options for copying.

You should now apply this method to other problems for practice.

**Activity 1**

Create a worksheet in Excel as follows:

i) Type “Sunday” in Cell A1 and drag it down up to Cell A7.

ii) Enter minimum and maximum temperature data for the past one week in your city. You may get this data from the newspapers. Obtain the temperature differences as explained in Sec. 1.6. Give a suitable name to your worksheet.


1.7 WORKING WITH FORMULAE

A mathematical formula is used to calculate a result based on data from one or more cells. It consists of some combinations of the standard mathematical operators (e.g., +, -, *, /), but may also include functions (e.g., Sqr(), Abs(), etc.). When we type a formula in a cell, that cell will generally display the result obtained by the formula, rather than the formula itself. Formulae automatically do calculations on the values in other specified cells and display the result in the cell in which we enter the numbers or type the formula. For example, when we type “=A2+B2” in Cell C2, it means that Cell C2 contains the sum of the values given in Cells A2 and B2. The value displayed in Cell C2 will then be a function of the numbers entered in Cells A2 and B2.

We first discuss the mathematical operations and their order before explaining how to type a formula in Excel.

1.7.1 Mathematical Operations

Excel applies the mathematical method of carrying out the calculations known as **BODMAS** rule, which defines the order of mathematical operations as follows:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brackets</td>
<td>(</td>
</tr>
<tr>
<td>of (order)</td>
<td>^</td>
</tr>
<tr>
<td>Division</td>
<td>/</td>
</tr>
<tr>
<td>Multiplication</td>
<td>*</td>
</tr>
<tr>
<td>Addition</td>
<td>+</td>
</tr>
<tr>
<td>Subtraction</td>
<td>−</td>
</tr>
</tbody>
</table>

For example, if we consider the formula “=4+2*5”, it gives the answer 14. You must have learnt this rule while studying arithmetic in school. Excel also does the multiplication before addition.

If we consider the formula “=(4+2)*5”, it gives the answer 30. Excel also does the addition in the brackets before multiplication.

There are many situations in which we need to use several brackets to type a formula in Excel. In such situations, Excel carries out the calculations of the innermost brackets first and then goes to the outer brackets.

If we consider the formula “=(4+2)*5+3/2”, it gives the answer 31.5. In this example, Excel first adds the numbers within the brackets, carries out multiplication and division in the formula and then adds the results as per BODMAS.

If we consider the formula “=(4+2)*5+3)/2”, it gives the result 16.5.

In this example, Excel adds the numbers within the inner brackets, then multiplies and adds the numbers within the outer brackets. Lastly, it divides as per BODMAS.

To perform calculations in Excel, you should keep two things in mind:

i) You should type the formula in the cell in which you wish the result to appear.

ii) All Excel formulae should start with the equal to (=) sign.

You should now apply this method to other problems for practice.
Activity 2

Solve the following exercises with the help of MS Excel 2007 and interpret the results:

i) \[
\left( \frac{8 \times 7}{2} \right) + 25 - \frac{20}{4} \times \left( \frac{15 - \frac{31}{1+7 \times 3}}{3} \right)
\]

ii) \[
\left( \frac{4 \times 3 + 25}{5 + 41} - \frac{75}{3} \right) \times 3 - 15
\]

iii) \[
\frac{2 + 3 - \frac{9}{3} + \frac{\left( \frac{8}{2} + 6 \times 2 \right)}{7}}{5} \times (2 + 3 - 4) + 12 - 2 \times 5
\]

1.7.2 Writing a Formula

We can use more than one mathematical operation in a formula typed in Excel and it will calculate the result using the BODMAS Rule.

However, we can also use brackets to change the order since any part of the formula which is contained within the brackets will be calculated first. Note that we can either press the Enter key or click the tick (✓) sign in the Formula Bar to get the results when we complete typing a formula (Fig. 1.53).

Fig. 1.53

We can also edit the formula later as follows:

1. We can double-click on a formula to edit it.
2. We can also edit the formula in the Formula Bar, but we must first click on the cell that contains the formula, to make it active.

Note that we can also use cell references to create a formula, which use the values contained in those cells for the calculation. For example, if we type “=A2-B2” in Cell C2, it will subtract the values of Cells A2 and B2 and display the result in Cell C2.

We can also use various functions of Excel, which are built-in functions such as Average(), Sum(), Var(), Sqrt(), etc. To apply these functions, we can choose the desired function available in Formulas group under Insert tab. We shall explain the use of these functions in the subsequent lab sessions.

We can also directly type these functions in the cell in which we wish to display the output.

Auto Fill Formula/Formula Auto Complete

We can directly type a built-in formula in the desired cell. Excel 2007 also
Note that formula which we type in Excel is not case sensitive, we can use upper as well as lower case. For example, if we wish to use \textit{Average} function, we can type \texttt{"=Average( )"}, \texttt{"=average( )"} or \texttt{"=AVERAGE( )"}.

Fig. 1.54

You should now apply this method to other problems for practice.

\textbf{Activity 3}

Type the following data in an Excel sheet and compute the per capita income for each family:

<table>
<thead>
<tr>
<th>No. of Members in a Family</th>
<th>Family Income (in ₹)</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>45000</td>
</tr>
<tr>
<td>3</td>
<td>40000</td>
</tr>
<tr>
<td>4</td>
<td>65000</td>
</tr>
<tr>
<td>5</td>
<td>55000</td>
</tr>
</tbody>
</table>

\textbf{1.8 EDITING AND FORMATTING THE WORKSHEET}

You have learnt how to create a worksheet, i.e., type data, apply formulae, etc., using Excel. We now explain how to edit and format the worksheet so that it becomes easier to handle the information stored in it and also makes it look better.

\textit{i) Changing the Row Heights and Column Widths}

While working on the worksheet, we also need to change the row height/column width many times. For example, we may wish to decrease the row height/column width to accommodate more information on a page, or increase it to accommodate the long value or text in a single cell. We can change the row height and column width using any one of the following methods:
a) We select the desired row(s) or column(s) to adjust the **row height/column width**, click on the **Format** option in **Cells** group under the **Home** tab on the ribbon and choose **Row Height/Column Width** option. We get the dialog box shown in Fig. 1.55b or c, respectively, if we select row(s) or column(s). We type a desired value of row height/column width in the dialog box as shown in Fig. 1.55.

![Fig. 1.55](image)

b) We can also use the shortcut mouse commands by right-clicking on the selected row(s) or column(s) and choose **Row Height** or **Column Width** option as shown in Fig. 1.56. We get the dialog box shown in Fig. 1.55b or c, respectively. We enter the desired value to adjust it according to the requirement.

c) We can simply adjust the **Row height/Column width** by dragging the lower border of the row (Fig. 1.57a) or right border of the column (Fig. 1.57b) with left-click of the mouse until we get the desired row height or column width.
d) We can also choose **Home → Cells → Format → AutoFit Row Height** or **AutoFit Column Width** (Fig. 1.55a) to adjust the selected row height or column width so that the widest entry in the column fits. Rather than selecting an entire column, we can just select cells in the column and the column is adjusted based on the widest entry in our selection.

e) We can double-click the right border of the column or lower border of the row to set the column width or row height automatically to adjust the wider entry in the column or row (Fig. 1.58).

**ii) Changing Number Format**

We can also use various number formatting options available in Excel to represent or change the appearance of the data in the worksheet. Excel offers 12 different number categories options such as **number**, **currency**, **date**, **time**, **percentage**, etc., as shown in Fig. 1.59.
To apply a specific number format, we
1. select the cell or range of data which we wish to format,
2. click on the arrow next to the **Number** format which opens the drop down **Number format list** as shown in Fig. 1.59, and
3. click on the suitable number category.

We can also click on the **More Number Formats** options shown in Fig. 1.59 to get the detailed formatting options. It opens the **Format Cells** dialog box (see Fig. 1.60).

![Figure 1.60](image)

In this dialog box, we can choose the desired number formatting option. When we wish to display data exactly as entered, we use the text format. For example, if we type the class interval “1-2” in Excel sheet, it will change to “01-Feb” by default. In this situation, we use the **Text** format to display it as “1-2”.

You can also explore other formatting options available in Excel.

**iii) Increasing and Decreasing Decimal Places**

For the numbers that are already entered on a worksheet, we can increase or decrease the number of places that are displayed after the decimal point for the numeric data using the **Increase Decimal** and **Decrease Decimal** buttons.

![Figure 1.61](image)

If we wish to increase or decrease the number of decimal places shown in a cell, or in the result of a formula, we
1. select the cell or range that contains the numbers for which we wish to change the number of places after decimal, and
2. click on the **Increase Decimal** or **Decrease Decimal** buttons in the **Number** group under the **Home** tab to display one more digit or one less digit after the decimal point.

   Note that **Increase Decimal** or **Decrease Decimal** options add or remove only one digit after the decimal at a time. To add or remove another digit, we have to click on these options again.

   For example, suppose we type the value “3.624” in Cell A2. If we wish to decrease the number of places after decimal, i.e., display 3.624 as 3.62, we

   1. select cell A2 that we wish to format,

   2. click on the **Decrease Decimal** button ( ) to decrease the number of places after the decimal as shown in Fig. 1.62a. The result is shown in Fig. 1.62b.

![Fig. 1.62](image)

By default, Excel displays 2 decimal places when we use a built-in **Number** format, such as **Number**, **Currency**, **Percentage**, etc. to the data. We can also change the number of decimal places after applying the number format.

In the same way, we can increase the number of places after decimal by clicking on the **Increase Decimal** button ( ) on the **Number** group under the **Home** tab.

We can also directly specify the decimal places. For this, we click on the arrow at the lower right corner on the **Number** group under the **Home** tab as shown in Fig. 1.59. The resulting dialog box is shown in Fig. 1.60. The default setting is 2 decimal places.

We can also use the shortcut mouse commands. For this, we select the cell or range, right-click the mouse and choose the **Format Cells** option as shown in Fig. 1.23. It opens the same dialog box as shown in Fig. 1.60.

Note that the increase and decrease options only change the appearance of the number and **do not change the actual number**. For example, suppose we have number 3.624 and if we decrease one digit after decimal, it appears as 3.62 but the number is still 3.624 and Excel uses 3.624 and not 3.62 for the calculations.

iv) **Wrapping the Text**

   In many situations, the line of the text entered in a cell may be wider than the cell itself. In such situations, the text may be hidden beyond the edges of the cell. Although we can resize the cell or column, we can also use the wrapping the text option. To wrap text within the cell, we

   1. select the cell or range of cells we wish to format, and

   2. click on the **Wrap Text** button on the **Alignment** group under the **Home** tab as shown in Fig. 1.63a.

The wrap text option wraps the text within a cell. It also increases the height of the row automatically. If it does not happen, we adjust the row height as explained in this section. This option shifts the text down according to the column width as shown in Fig. 1.63b.
v) Merging the Cells
We can also merge two or more adjacent cells in Excel. When we merge two or more adjacent horizontal or vertical cells, we get one large cell. To merge cells, we

1. select the cells or range, which we want to merge, and
2. click on the Merge & Center option on the Alignment group under the Home tab as shown in Fig. 1.64a.

We can also click on the arrow located next to the Merge & Center button and choose the required merging option from the options shown in Fig. 1.65.

vi) Applying a Background Colour
We can change the background colour of the cells using the Fill Color option available in Excel to highlight or show that the information given in those cells is important. As shown in Fig. 1.66, to apply a background colour, we

1. select the cell or range on which we wish to apply a background colour,
2. click on the arrow next to the Fill Color button on the Font group under the Home tab (which provides a collection of different background colours), and
3. select the colour we wish to apply on the background of the selected cells.
vii) Print Screen Option to Capture a Screenshot

In each session of the lab course, you will need to capture the screen of the required results and charts, which is a snapshot of the monitor screen. The Print Screen key often abbreviated as Print S C r n, P r t S c r n, P r t S c r, P r t S c e or P r S c e, etc., is generally placed near the Insert key on the keyboard and also sometimes shares a key with System Request (S y s R q).

When we press Print Screen, it creates an image of the screen in the clipboard. We then open a word document and click on the Paste option under the Home tab of the Word document. It pastes the screenshot in this word document.

1.9 DATA ANALYSIS TOOLPAK

Since we shall apply many techniques for data analysis in Excel worksheet using the Data Analysis Toolpak, it is necessary to activate it on your computer. The Analysis Toolpak is an add-in of the Microsoft Office Excel which is available when we install Microsoft Office or Excel. Data Analysis Toolpak is a collection of 19 data analysis tools used for statistical analysis. The analysis tools included in the Data Analysis Toolpak enable you to analyse the worksheet data using ANOVA, F-test, t-test, regression, correlation, descriptive statistics, etc.

This Data Analysis Toolpak comes with Excel 2007. But when we use it for the first time, we may have to install it or activate it. To activate the Data Analysis Toolpak, we click on the Microsoft Office button and then click on Excel Options button as shown in Fig. 1.67.
The *Excel Options* opens a new dialog box as shown in Fig. 1.68. We click on the *Add-Ins* option in the left pane. The *Add-Ins* tab contains a list of all add-in programs installed on the computer.

![Excel Options dialog box](image)

**Fig. 1.68**

We select *Excel Add-ins* from the *Manage* box at the bottom and click on *Go*. It opens a new dialog box as shown in Fig. 1.69.

![Add-Ins dialog box](image)

**Fig. 1.69**

We select the *Analysis ToolPak* box in the available *Add-Ins* list and then click on the *OK* button. If an alerting dialog box appears asking you to install the add-in, click on *Yes* and wait for Excel to configure the add-in as shown in Fig. 1.70.
After we activate the **Analysis ToolPak**, the **Data Analysis** command will be available in the **Analysis** group under the **Data** tab as shown in Fig. 1.14.

### Continuous Assessment 1

A researcher wished to study the percentage of male and female students in a college. For this, she collected the number of male and female students enrolled in a particular programme of the college for 20 years from 1991 to 2010. The data are recorded in Table 2.

<table>
<thead>
<tr>
<th>S.No.</th>
<th>Year</th>
<th>Number of Students</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Male Students</td>
</tr>
<tr>
<td>1</td>
<td>1991</td>
<td>321</td>
</tr>
<tr>
<td>2</td>
<td>1992</td>
<td>296</td>
</tr>
<tr>
<td>3</td>
<td>1993</td>
<td>375</td>
</tr>
<tr>
<td>4</td>
<td>1994</td>
<td>402</td>
</tr>
<tr>
<td>5</td>
<td>1995</td>
<td>331</td>
</tr>
<tr>
<td>6</td>
<td>1996</td>
<td>387</td>
</tr>
<tr>
<td>7</td>
<td>1997</td>
<td>442</td>
</tr>
<tr>
<td>8</td>
<td>1998</td>
<td>378</td>
</tr>
<tr>
<td>9</td>
<td>1999</td>
<td>435</td>
</tr>
<tr>
<td>10</td>
<td>2000</td>
<td>498</td>
</tr>
<tr>
<td>11</td>
<td>2001</td>
<td>425</td>
</tr>
<tr>
<td>12</td>
<td>2002</td>
<td>447</td>
</tr>
<tr>
<td>S.No.</td>
<td>Year</td>
<td>Male Students</td>
</tr>
<tr>
<td>-------</td>
<td>------</td>
<td>---------------</td>
</tr>
<tr>
<td>13</td>
<td>2003</td>
<td>521</td>
</tr>
<tr>
<td>14</td>
<td>2004</td>
<td>435</td>
</tr>
<tr>
<td>15</td>
<td>2005</td>
<td>465</td>
</tr>
<tr>
<td>16</td>
<td>2006</td>
<td>568</td>
</tr>
<tr>
<td>17</td>
<td>2007</td>
<td>563</td>
</tr>
<tr>
<td>18</td>
<td>2008</td>
<td>498</td>
</tr>
<tr>
<td>19</td>
<td>2009</td>
<td>556</td>
</tr>
<tr>
<td>20</td>
<td>2010</td>
<td>621</td>
</tr>
</tbody>
</table>

- Type the data of Table 2 in Excel in the same format as given.
- Use merging option for typing the text “Number of Students”.
- Use the wrapping text option to wrap the phrase “Male Students” and the phrase “Female Students”.
- Type 1 and 2 in Cells A3 and A4, respectively, select Cells A3:A4 and drag them down or fill down, up to Cell A22 to fill the serial numbers.
- Apply **Fill down** or **Drag down** option to enter the years.
- Calculate the total number of students for each year.
- Insert a column after “Male Students” and calculate the percentage of male students for each year in the inserted column.
- Insert a column after “Female Students” and calculate the percentage of female students for each year in the inserted column.
- Save this file with the name **“Continuous Assessment 1”** in D drive of your computer.
- Rename the sheet as **“Students’ Data”**.
- Decrease the decimal up to 2 places for the percentage of male and female students.
- Highlight the minimum and maximum percentage of male and female students with light orange and purple colour, respectively.

---

**Home Work: Do It Yourself**

1) Follow the steps explained in Secs. 1.2 to 1.9 to learn how to work with MS Excel 2007. Take the final screenshots of the tasks and activities done in Secs. 1.2 to 1.9 and keep them in your record book.

2) Develop the spreadsheet for the “Continuous Assessment 1” as explained in this lab session. Take the screenshots of the final spreadsheet.

3) **Do not forget** to keep all screenshots in your record book as these will contribute to your continuous assessment in the Laboratory.