1.1 INTRODUCTION

The Microsoft Excel is a part of the Microsoft Office suite. It is the most widely used spreadsheet application for organising and analysing data, creating tables and charts, etc. Microsoft Excel is also commonly used to perform different types of complicated numerical calculations for the given data.

This spreadsheet application is used to store information in columns and rows, which can then be organised and processed. Spreadsheets are designed to work well with numbers but often include text. Excel organises your work into workbooks and each workbook can contain many worksheets. These worksheets are used to list and analyse data. Excel is generally available on all public access PCs (e.g., in the Library and PC Labs).

In this lab session, we introduce MS Excel 2007. We also explore the basic concepts, functions, editing and formatting, etc., in Excel which are useful for this lab course. You will study the applications of various statistical tools using Excel 2007 in the subsequent lab sessions.

Objectives

After performing the activities of this session, you should be able to:

- start Excel 2007 and enter data in the worksheet;
- create and type the formulae;
- edit and format the worksheet;
- develop the spreadsheet in MS Excel 2007; and
- work with MS Excel 2007.

## 1.2 HOW TO START EXCEL 2007

The Excel program is located in the **Microsoft Office** folder. To use MS Excel, we first start the computer. We can open MS Excel by double clicking on the MS Excel icon (shortcut) which is on the desktop or using the Windows button. If the PC has Windows 7, we open MS Excel using the Windows button by selecting **Windows → All programs → Microsoft Office → Microsoft Office Excel 2007**. As shown in Fig. 1.1, we

1. click on the **Windows** icon (**スタート** in Japanese) (which is at the lower left corner of the monitor screen) as shown in Fig. 1.1a,
2. point or click on **All Programs** which displays the list of all programs,
3. click on the **Microsoft Office** folder from the sub-menu (which displays the list of **Microsoft Office** applications) as shown in Fig. 1.1b, and
4. click on the **Microsoft Office Excel 2007** under the **Microsoft Office** folder (Fig. 1.1b). The Microsoft Excel window shown in Fig. 1.3 appears on the monitor screen.

![Fig. 1.1](image)

(a)  (b)  
If the shortcut icon does not appear on the desktop, we can also create a shortcut of MS Excel on the desktop. As shown in Figs. 1.1a, b and 1.2a, we

1. click on the **Windows** icon (Fig. 1.1a),
2. click on **All Programs** (Fig. 1.1a),
3. click on the **Microsoft Office** folder (Fig. 1.1b),
4. right-click on the **Microsoft Office Excel 2007** (Fig. 1.2a), and
5. click on the **Desktop (create shortcut)** option under **Send to** menu (Fig. 1.2a).

The Excel shortcut shown in Fig. 1.2b appears on the desktop.
1.3 BASICs OF Excel 2007

When we start Excel, the Excel spreadsheet appears within a few moments on our monitor screen. It looks similar to Fig. 1.3. Before we start working on the Excel spreadsheet, we briefly discuss various parts of the Excel spreadsheet shown in Fig. 1.3.

**Fig. 1.3: Various parts of the Excel spreadsheet.**

1. **Microsoft Office Button**
   The Microsoft Office sign at the upper-left corner (Fig. 1.3) of the Excel window is called the Microsoft Office Button. It is basically used for handling files. A close-up view of the Microsoft Office Button is shown in Fig. 1.4a.
When we click on this button, it provides several options such as **New**, **Save**, **Print**, **Close**, etc., as shown in Fig. 1.4b.

2. **Workbook**

   Notice from Fig. 1.3 that the title bar is labelled “**Book 1 Microsoft Excel**”. This MS Excel document is called a **workbook**. Each workbook comprises one or more **worksheets**. By default, it contains three worksheets (Fig. 1.5).

3. **Worksheet**

   The lower left corner of the Excel window (Fig. 1.5) initially has three worksheets labelled **Sheet 1**, **Sheet 2**, and **Sheet 3**, which are called the **Worksheet** or **Sheet** tabs. We can say that a workbook is like a file into which we can place as many worksheets as memory allows. By clicking on these **Sheet** tabs with the mouse, we can display the contents of that particular worksheet. The current worksheet is called the **Active sheet**. Each worksheet is made up of multiple grids of cells in the form of rows and columns.

4. **Columns**

   We have **alphabetically** titled columns ranging from **A** to **XFD**, i.e., there are a total of **16,384** columns in a worksheet. We can select the entire column by clicking on the column title.

5. **Rows**

   We have **numerically** titled rows ranging from **1** to **1,048,576**, i.e., there are a total of **1,048,576** rows in a worksheet. We can select the entire row by clicking on the row title.
6. Cells
Cells are the basic rectangular building blocks of a spreadsheet. They are assigned an address, generally referred to as a cell reference, according to their column and row labels (e.g., the cell in Column H at Row 11 is referenced as Cell H11). In this way, we have a total of $17,179,869,184$ cells in an Excel sheet. Each cell can contain a label, value or formula. Labels can contain any combination of letters, numbers, or symbols. Values are the numbers and only values (numbers) can be used in calculations. A value can also be a date or time.

7. Active Cell
A cell having dark border (outline) is called the active cell. In Fig. 1.6, Cell A4 is the active cell. A small black square called the fill handle is displayed at the bottom right corner of the active cell.

![Fig. 1.6]

8. Excel Close Button
We can close the Excel application window by clicking on the Excel Close button as shown in Fig. 1.7.

![Fig. 1.7]

9. Workbook Close Button
We can close the active workbook by clicking on the Workbook Close button as shown in Fig. 1.7.

10. Minimise and Maximise/Restore Buttons
We can minimise Excel/Workbook by clicking on the Excel/Workbook Minimise button. We use Excel/Workbook Maximise/Restore button to maximise or restore (unmaximise) the Excel/Workbook size (Fig. 1.7).

11. Ribbon
It contains the commands in Excel and has three parts: tabs, groups and commands. We shall elaborate on it in Sec. 1.4.

12. Horizontal and Vertical Scrollbars
We can scroll the sheet horizontally and vertically, respectively, using the Horizontal and Vertical Scrollbars.

13. Quick Access Toolbar
We can customise the most commonly used commands on the quick access toolbar as shown in Fig. 1.8.
When we have committed an error, we can reverse the action using the **Undo** command or by pressing **Ctrl + Z** keys. We can reverse the last 100 actions which we have performed using the **Undo** command before closing the file. The **Redo** command or **Ctrl + Y** keys perform in the reverse direction of the **Undo** command. It restores the actions for which we have used the **Undo** command.

In Fig. 1.8, the Quick Access Toolbar consists of **Save File** ( ), **Undo**  and **Redo**  icons.

14. **Formula Bar**
When we enter or type a formula and other information in any cell, it appears in the formula bar. For example, if we type **Statistics** in any cell, say, Cell B2, it also appears in the formula bar (Fig. 1.9).

15. **Name Box**
The name box is on the left side of the formula bar. If we click on a cell, we can see that its name appears on the name box. If we click on a different cell, the name will change accordingly (Fig. 1.9).

### 1.4 **THE RIBBON**

The Ribbon is a panel that contains eight tabs. Each tab is related to a specific task and contains several groups of related commands, menus or lists. Note that some of these groups have an arrow ( ) in the bottom right corner of that group. We get a dialog box which contains all commands of that group when we click on it. We briefly elaborate on the look of the ribbon for all eight tabs, groups within each tab and commands within the groups as follows:

1. **Home Tab**
The home tab contains the following groups within the tab and commands within the groups (Fig. 1.10):

   i) Clipboard (cut, copy, paste, etc.)
   ii) Font (font type, font size, etc.)
   iii) Alignment (left, right, justified, etc.)
iv) Number ($, %, decimal, etc.)
v) Styles (format tables, cells, etc.)
vi) Cells (insert, delete cell(s), rows or columns, etc.)
vii) Editing (fill, find & select, etc.)

Remember, the look of the ribbon may vary with the screen resolution.

2. **Insert Tab**

   It is used to create tables, charts, etc., and contains the following groups within the tab and commands within the groups (Fig. 1.11):

   i) Tables (pivot table and tables)
   ii) Illustrations (picture, clip art, etc.)
   iii) Charts (column, line, pie, scatter, etc.)
   iv) Links (hyperlink)
   v) Text (text box, object, symbol, wordart, etc.)

![Fig. 1.11](image)

3. **Page Layout Tab**

   It is used for setting the page layout and contains the following groups within the tab and commands within the groups (Fig. 1.12):

   i) Themes (colors, fonts, etc.)
   ii) Page Setup (margins, orientation, background, etc.)
   iii) Scale to Fit (scale, height, etc.)
   iv) Sheet Options (gridlines, heading, etc.)
   v) Arrange (selection pane, align, etc.)

![Fig. 1.12](image)

4. **Formulas Tab**

   It is used to apply a formula for numerical calculations and contains the following groups within the tab and commands within the groups (Fig. 1.13):

   i) Function Library (insert function, autosum, math & trig, etc.)
   ii) Defined Names (name manager, define name, etc.)

![Fig. 1.13](image)
iii) Formula auditing (show formulas, remove arrows, etc.)
iv) Calculation (calculation options, calculate now, etc.)

5. **Data Tab**

It contains the following data related groups within the tab and commands within the groups (Fig. 1.14):

i) Get External Data (from text, web, etc.)
ii) Connections (connections, refresh all, etc.)
iii) Sort & Filter (sort, filter, etc.)
iv) Data Tools (text to columns, data validation, etc.)
v) Outline (group, ungroup, etc.)
vi) Analysis (data analysis)

*Note:* If the Data Analysis command under Data tab (far right) does not appear on your computer, you need to activate it (see Sec. 1.9).

![Fig. 1.14](image)

6. **Review Tab**

This tab contains the following groups within the tab and commands within the groups (Fig. 1.15):

i) Proofing (spelling, thesaurus, etc.)
ii) Comments (new comments, previous, etc.)
iii) Changes (protect sheet, protect workbook, etc.)

![Fig. 1.15](image)

7. **View Tab**

The view tab contains the following groups within the tab and commands within the groups that control various aspects of how a sheet is viewed (Fig. 1.16):

i) Workbook Views (normal, page layout, etc.)
ii) Show/Hide (gridlines, ruler, etc.)
iii) Zoom (zoom, 100%, etc.)
iv) Window (new window, split, hide, etc.)
v) Macros (macros)

![Fig. 1.16](image)
8. Developer Tab
This tab is generally not visible by default. It contains commands that are useful for programmers (Fig. 1.17). To display the developer tab, we click on Excel Options under Office button and then select Popular. We check the box next to Show Developer Tab in the Ribbon.

![Developer Tab](image)

Fig. 1.17

Besides these tabs, you will also come across three chart tool tabs: Design, Layout and Format when you create any chart. These tabs are useful to deal with charts (Fig. 1.18). You can access these tabs by clicking on the chart you have created.

![Chart Tool Tabs](image)

(a)

![Chart Tool Tabs](image)

(b)

![Chart Tool Tabs](image)

(c)

Fig. 1.18

1.5 WORKING WITH EXCEL 2007

While working with Excel 2007, you must keep the following points in mind:

1. **File Format**

The most common data formats used to store data in Excel files are as follows:

- Excel workbook with extension .xlsx means that the file is in Excel 2007 format. This may not be recognised by earlier versions of Excel such as Excel 97 or Excel 2003. We can also access an Excel file in lower version of Excel if we save it in a compatible mode.

- Excel workbook with extension .xls means that the file is in a version lower than Excel 2007.

2. **Creating a New File**

When we start Excel application, we get a blank workbook (Fig. 1.3) by default. We can also open a new workbook whenever we desire. We can create a new workbook by clicking on the Office button and selecting New from the menus as shown in Fig. 1.19a. A new dialog box appears. We select Blank Workbook option and click on Create as shown in Fig. 1.19b. This gives us a new screen with a blank workbook area.

When we open Excel 2007, it creates a workbook, which contains 3 worksheets by default.

Open the workbook to start your work on Excel worksheet. To create a new workbook, click on File → New → Blank Document (or press Ctrl+N).

Click on File → Open (or press Ctrl+O) to open/retrieve an existing workbook.
3. Opening an Existing File

If we want to use or continue working on a workbook that we have created earlier, we click on the **Office** button and then on the **Open** button as shown in Fig. 1.20a. A new dialog box appears (Fig. 1.20b). Then we select the path of the folder where we have saved the file, select the required file and click on the **Open** button to open the file. This will open the required file. We shall explain this option with an example in Sec. 1.6.

4. Saving a File

We need to make a secure copy of the workbook in the form of a file to save the work. We click the **Office** button and select the **Save** option as shown in Fig. 1.21a. We can also click on the **Save** button (Fig. 1.8) on the **Quick Access Toolbar** to save the file. If we are saving the file for the first time, a dialog box opens (Fig. 1.21b). In this dialog box, we type a suitable name for the workbook file in the **File Name** box and specify the location where we want to save it from the left pane shown in Fig. 1.21b. The location can be any folder on the hard disk. Initially, Excel offers the **Documents** folder. But we can change this by selecting a new drive or folder.
Note that you should first save the workbook on the hard disk with a suitable name, which will help you identify the files of the lab sessions, e.g., for Lab Session 1 of Basic Statistics Lab, you can use the file name “BS_LS_1” or any other name of your choice. We click on the **Save** button to save a file after typing its name. All subsequent saves will update the existing file without asking for a file name. You can also use the separate sheet within this workbook for each activity, problems and continuous assessment.

![Select this](image)

![Click on this](image)

**Fig. 1.21**

If you wish to save an existing file again with another name or make a copy of the file, choose the **Save As** option instead of **Save**. It is very important that you should save results frequently to avoid losing a file.

5. **Closing a File**

When we have finished working on a document, we close it. To close a file, we click on the **Office** button and select **Close** from the menu (Fig. 1.22), or click on the **Close** button in the workbook window (Fig. 1.7). If you have made any changes since saving the file earlier, Excel will ask you to save it. To close Excel, we click on the **Office** button and click on the **Exit Excel** option (Fig. 1.22) or click on the **Close** button in Excel window (Fig. 1.7).
6. **Shortcut Mouse Commands**

   In addition to the **Ribbon** commands explained in Sec. 1.4, Excel also provides shortcut menu options for some commands. We get these shortcut menus when we press the right button of the mouse, i.e., right-click the mouse. We can also use these shortcut mouse commands to edit the cell(s)/row(s)/column(s). We select the cell(s)/row(s)/column(s) and right-click the mouse button. It opens a shortcut of the list of commands at the mouse pointer position (Fig. 1.23).

   For example, when we select Cell A4 and right-click the mouse, certain shortcut mouse commands appear as shown in Fig. 1.23. This shortcut menu shows all options that we can use for the cell(s)/row(s)/column(s).

7. **Renaming a Worksheet**

   As shown in Fig. 1.24, to rename a worksheet, we

   1. click on the **Format** option in the **Cells** group under the **Home** tab,
   2. click on the **Rename Sheet**, and
   3. type a suitable name.