
 

Unit1 Introduction to EXCEL 
 
 

1.0 Introduction 
 
MS-Excel is a Windows based application package that can be used to automate tasks such as calculation 
and analysis of data. 
 
MS-Excel works the way you want i.e. it can be customised. It provides ease of work with the following 
features: 
 
Tip Wizard - Guides you to work more effectively while you work by displaying various helpful tips and 
techniques based on what you are doing. 
Drag and Drop Feature - It help you to reposition the data and text by simply dragging the data with the 
help of mouse. 
 
Autofill - It helps you to fill rows or columns with the series of data. 
 
Autosum - You can add a large range of data by simply selecting a tool button. 
Windows Interface - As Excel is Windows based package therefore the user interface is consistent. 

Shortcut Menus - Commands appropriate to the task that you are doing appear by clicking the right mouse 
button. 

Built-in Spell Check - You can maintain a dictionary of the words usually used in your work and spell-
check your spreadsheet. 

 

1.1 Objectives 
 
After studying this unit, you will be able to 
 
Discuss the EXCEL basics, start EXCEL, create a workbook 
Enter and Edit data in the worksheet of EXCEL 
Navigate the worksheet, search, replace and rearrange the cell contents in the worksheet 
Get the idea of saving the workbook using a password for protection. 
 

1.2 Excel Basics 
 
Before you start working on the worksheet, the knowledge of the concepts and movement on the workbook 
is necessary. 
 

1.2.1 To Start Excel 
 
1. Start Windows. 
2. Click on the Program Manager icon. 
3. In the Program Manager window, click on MS-Office icon. 
4. In the MS-Office window, click on MS-Excel icon as shown below: 



 

1.2.2 Workplace of Excel Spreadsheet: 
 

 

Menu Bar - Different options for selection. 

Standard Toolbar - It is displayed by default and provides shortcuts for the common commands used. 

Formula Bar - Any text, data or formula that is being keyed-in or edited is displayed in it. 

Name Box - Displays the address of the current cell. 

Scroll Bars - Used to move up or down in the worksheet using mouse. 

Sheet Tab - Displays the name of the current worksheet that can be changed by double clicking on it and 
giving a new name in the dialogue box. 

Status Bar - Left part displays the various messages like Ready mode (when Excel is ready to accept data 
into the spreadsheet) or Edit mode (while in the editing mode). The right part highlights the status of keys 
of the keyboard. 

Row Headings - They are numbered as 1, 2, 3 .... 16384. 



Column Headings - These are addressed as A, B, C,....IV. 

Active Cell - Intersection of each row and column is called a cell. 

 

1.3 Worksheets within Workbook 
 
MS-Excel document is called as a Workbook. Each Workbook contains 16 worksheets by default. This 
number can be changed if required by  resetting the default options. Worksheets within Workbooks make it 
easy to bind files of related information. When a Workbook is opened, all worksheets of that workbook 
become available to the user automatically. 
 

1.4 Getting started with EXCEL 
 
Firstly, open the workbook to start your work on a worksheet. At times, you might require to insert or 
delete a worksheet, and cells to be selected. 
 

1.4.1 Create a Workbook 
 
Select the New.. command from the File menu. The Workbook is opened by the default name of BOOK1. 
 

1.4.2. Open a Workbook 
 
To open an existing Workbook, select Open option from the File menu.  Names of the recently used files 
are listed in the File menu and can be selected by merely clicking on the name of the file to be opened. 
 

1.4.3. Find a Workbook 
 
Choose File -> Open command. Select Find File.. option from the dialogue box that is 
opened. Consequently, another dialogue box is opened in which the details like file name, directory are to 
be given. 
 

1.4.4. Insert a Worksheet 
 
To insert a Worksheet between two worksheets choose Worksheet option from the Insert menu. 
 

1.4.5. Delete a Worksheet 
 
To remove a worksheet from the workbook, select Delete Sheet from the Edit menu. A dialogue box will 
appear to confirm this action. 
 

1.4.6. Move the Worksheet 
 
To move the worksheet in the same workbook, place the mouse pointer on the sheet tab, press the left 
mouse button and drag it to the desired position. Release the button. 
 

1.4.7. Selecting Cells 
 



You can select a single cell or a group of cells using mouse or keyboard. 
Using Mouse -  
 
Click on the cell with the left mouse button. That cell gets selected and becomes the active cell. Whatever 
you type goes into this cell. To select a range of cells, click on one cell, hold down the left mouse button 
and drag the mouse pointer to the last cell of the range you want to select. 
Using Keyboard- 
 

To Select Press 

Current Cell Enter 
Entire Column Ctrl + Spacebar 
Entire Row Shift + Spacebar 
Entire Worksheet Ctrl + Shift + Spacebar 
Extend Selection to End of End, Shift + Arrow key 
Data Block 
 

 

1.5 Enter and Edit Data 
 
The various kinds of entries that can be made in a cell are : 
Text - First select the cell in which the data has to be entered and type-in the text. 
 
Press ENTER key to finish your entry. The data will be displayed in the active cell as well as in the formula 
bar. To enter digits as text (calculations cannot be done using these kind of entries ) use an apostrophe (') as 
the first character. 
 
Number - Numbers include digits from 0 to 9 and some special characters like  

$  %  +  -  /  (  )  ,  .  E  e 
 
Date and Time - Date and Time entries are interpreted in a special way in Excel. They are represented as 
numbers for Excel given to each day from 01:01:1900 (serial number 1) to 31:12:2078 (serial number 
65380). Although when you type a date in the cell like 01/01/97, it will be displayed as it is.  
 
Example : Type TODAY() in a blank cell and press ENTER key. 

(This function will display the system date and time) 
 
Data in Series- You can fill a range of cells either with the same value or with the series of values. This 
can be done using Autofill handle (small square on the bottom-right corner of the active cell) 
 

 
 
Drag this handle till the last cell to create a range of  cells which are to be filled-in with the values. 
Example :  



1. Enter MONDAY in cell E20. 

2. Drag the Autofill handle till the cell K20. 

( The whole range will be filled with days from MONDAY to SUNDAY. ) 

To create a series of numbers 

 
 

Example : Select the cell H20 and enter 1 in it. 
 
        Select the range from H20 to H11.  
 
Though Excel provides the facility of built-in lists (e.g. MONDAY to SUNDAY) to perform Autofill, the 
users can also create their own custom lists which are used frequently in your worksheets. 
 

1.5.1. To Create a Custom List 
 
1. Enter the given list starting from cell L5 to L8 
LEFT 
RIGHT 
UP 
DOWN 
2. Select this range of cells. 

3. Select Options.. from Tools menu. 

4. Select Customs tab from the Custom dialogue box. 

5. Click on OK. 
or 

1. Select Tools -> Options  
2. Click on Custom List tab 
3. Type the custom list in the List Entries Box. 
4. Click on OK. 
 



Data, if written incorrectly, can be edited by following ways : 
 
1. Select the cell with some value to be edited. 
2. Press F2 and using Backspace key erase the previous entry. You can retype the correct data. 

or 
Simply select the cell and retype the entry. 
To bring back the previous entry either click on Undo button on Standard Toolbar or choose Edit -> Undo 
option. 

or 
Pressing Alt + Backspace or ctrl-Z keys can also be used to perform the undo task. 

or 
To clear the cell entry, select the cell to be cleared and press Delete key. 
 

1.5.2 Cell References 
 
There are 16384 rows and 256 columns in one worksheet. The first cell is labelled as A1 (column as A and 
row number as 1)or R1C1. 
 
Example :- R3C3 refers to row 3 column 3 and is equivalent to C3. Thus he last cell is labelled as IV16384. 
This is called the cell address and they reused to identify the cell. 
Cell references are given in different ways : 
 
Relative - This refers to the cell relative to the given position. 
 Example : Enter the following values : 
   In cell A3 enter the value 34 
   In cell A4 enter the value 23 
   In cell A5 enter the value 89 
   In cell A6 enter the formula = A3 + A4 + A5 
   Copy this formula to the cell A7, and see the result. 
 
Observe the formula entered in cell A7. It is A4 + A5 + A6. The formula entered in cell A6 means the sum 
of the values given in the three cell given above the current cell. Therefore when we move down, the 
relation specified in the formula was copied ( i.e. the three values given above the current cell which is A7 
now ). 
 
Absolute - This refers to the specific cell irrespective of the position of the formula. The '$' sign is used to 
denote an absolute reference.  
 
Example : In the cell B3 copy the formula $A$3 + $A$4 + $A$5 
               Copy this formula to the cell B4. 
 We find that the result and the formula remains the same. 
 
Mixed - It is a combination of both relative and mixed references. It has one absolute co-ordinate and one 
relative co-ordinate. $D1 and D$1 are both examples of mixed references. 
 

1.6 Range Names 
 
A name can be given to a single cell or a range of cells (e.g. B3:F9). The range name can be used in place 
of these cell references. Also the range specified for a range name can be modified. 
To define a name, following points have to be considered :- 
 
1. Name contain only letters from A-Z, or a-z, numbers 1-9, the  period (.) and the underscore (_). 
2. Maximum length can be upto 255 characters. 
3. Name cannot be same as cell reference like $F$10 or F10. 



4. Spaces are not allowed. 
 
 Valid Range Names   Invalid Range Names 

    Months    First Name 

    Final_year    5 Days 

    Date_of_join    R5C12 

    Basic_salary 

    Year5 

Ways to create name 
Using Name Box 
 
1. Select the range of cells. 
2. Click on Name Box on Formula Bar and type the name. 
 
You'll will be warned if the same name is given which has already been defined. 

Using Define Name Dialogue Box 
1. Select the range of cells. 
2. Choose Insert -> Name -> Define. 
 
 Specify the Range Name in this text box 
 

 
     Range of cells 
Using Create Name Dialogue Box 
 
1. Enter the given data. 
 



 
 

2. Select the range B2:C5. 
3. Choose Insert -> Name -> Create. This will display the Create Names dialogue box. 
4. Press OK.  
 

1.7 Navigate Worksheet 
 
With Mouse 
 
You can move the mouse pointer to move to any cell of any worksheet of the workbook. This is done 
through:- 
 
1. Click on up-arrow or down-arrow button on the scroll bar. 
2. Click on the sheet tabs. 
3. Click on any cell. 
4. To move quickly to any cell Choose Edit -> Goto. 

With keyboard 
 

TO MOVE KEY PRESSED 

Right, Left, Up, Down one cell Arrow Keys 

Up or Down one screen PgUp or PgDown 

Beginning of row Home key 

To cell A1 Ctrl+Home 

To lower right corner Ctrl+End 

To last cell in current row End or Enter key 

To lower right corner of window End (with Scroll Lock on) 

To upper left corner of window Home (with Scroll Lock on) 

 

1.8 Search and Replace Data 
 
To look for the data which is entered by the user, choose Edit -> Find. 



 

 
To replace the data, click on Replace... button  

or 
   Choose Edit -> Replace. 
 

1.9 Rearrange Cell Contents 
 
Rearranging cell contents includes moving or copying or clearing cell contents. This also involves inserting  
or deleting rows or columns. This can be done either by cut and paste method or drag and drop method. 
 

1.9.1 Move or Copy Cell Contents -  
 
Drag and Drop method 
 
1. Select the range of cells which are to be moved. 
2. Point to the border of range. The mouse pointer will change its shape to an arrow. 
3. To move, press the left mouse button, drag it to the new location and release the mouse button. 
4. To copy, press the Ctrl key while dragging the contents. 
 
Short-cut menu 
 
1. Press the right mouse button while dragging and dropping cell contents. 
2. From the short-cut menu, choose Move to move the contents, or choose Copy to copy the contents. 

 

Cut and Paste Method 
1. Select the cell range. 
2. Select Edit -> Cut ( to move the range of cells ) 
   or 
3. Select Edit -> Copy ( to copy the range of cells ) 
4. Select the upper left corner of the new location where you want to place the cell contents. 
5. Choose Paste option from Edit menu. 
 

1.9.2 Inserting or Deleting Rows and Columns 
 
Many a times you may require to add a row of data or a column of data which you forgot to enter earlier. 
Excel provides you the facility to insert rows or columns into the existing worksheet very easily. 
One thing which has to be taken care of is that inserting a row of data will shift the rest of the rows down 
and cause the last row of the worksheet to be removed. Same is the case while we insert a column in the 



worksheet, the rest of the columns shift right. This happens because the total number of rows and columns 
remain the same. If there is any data in the last row or column of the worksheet that will be lost. 

To insert cells, rows or columns 
1. Select the cell(s) where you want to insert the cell(s), row or column. 
2. From the Insert menu, 

i. Choose Entire Column to insert the column 
ii. Choose Entire Row to insert the row 

 
Choose Shift Cells Right or Shift Cells Down to insert the cell(s). 
 

1.10 Save and Protect Workbook 
 
After you finish up your work with the workbook you will require it to be saved so that it can be opened 
later to resume the work in it. 
 
To give the name and save the workbook -  
 Choose File -> Save As command 
To simply save the workbook -  
 Choose File -> Save command 
    or  
 Click on the Save File Tool button 
 

 
 
To protect the Workbook - Your data can be very confidential which has to be saved from unauthorised 
people.  
 
Click on Options... button from the File -> Save As dialogue box. 
 



 
 

You can restrict the access of that workbook from other users in 3 different ways: 

Protection Password 

1. Type the password which will be required to open the workbook. The password can be upto 15 
characters long, can include alphabets (upper case or lower case), numbers and special characters. It is 
case sensitive also.  

2. You will be asked to re-enter the same password. 

3. Click on OK. 

Write Reservation Password 
This password will be required when you make changes in the existing workbook and then try to save that 
workbook. This prevents the unauthorised users to make any modifications in the workbook. The rules to 
give the password are same as Protection Password. 

Read-only Recommended 
If this option is checked, the following dialogue box will be displayed every time you try to open the 
workbook. 



 
This option is checked if you want to discourage the other users from making any changes by mistake or 
you want to prevent the changes to be made by more than one users simultaneously (this is possible when 
more than one users are working on the same workbook). 
 

1.11 Exit EXCEL 
 
When your work is finished and it has been saved properly, to close the file and exit MS-Excel, 
 
1. Choose File -> Close command. 
2. Choose File -> Exit. 
 
If you have not saved your work before closing the file, the dialogue box to save the worksheet is 
displayed. 
 

1.12 Summary 
 
In this session, you learned  
 
1. What is an Excel workbook and worksheet, and how to work in it.  
2. Data is entered in the cells and can be edited, if required. 
3. Names can be given to a single cell or a range of cells. 
4. You can move in the worksheet either with keyboard, mouse or menu. 
5. Data which has been entered can be searched and replaced. 
6. The contents of the cell can be copied and moved anywhere in the workbook. 
7. The worksheet which has been created can be saved and you can also protect it from unauthorised 

users by giving passwords. 
8. Commands to leave the Excel workplace and come out to Windows shell. 
 

1.13 Exercise 
 
1. What are the different features of Excel that provide the ease of work. 
2. Dfferentiate between a Workbook and a Worksheet. 
3. What are the different types of data that can be entered in Worksheet cells ? 
4. What is Fill-handle and how is it useful ? 
5. Explain the three ways of referencing the cells. 
6. What are the different ways to name or copy cell contents ? 
7. How the access of the Workbook can be restricted from other users ? 
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